Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hello....
#1
The old man is giving up on his Rover 75, and is receiving counselling on their forum, so I thought I would put my beloved Berlingo Multispace back on the road after 4 years hibernation and join you lot.
Started first time, MoT failed on a front spring and track rod end, so pretty chuffed with that.
Him indoors says there is an 'intermittent fuel delivery issue, presenting as a slight misfire or stutter" but he could be talking Martian as far as i Know.
We might even convert it into a simple stealth camper.....
Reply
#2
If its been stood for 4 years it could be bad fuel, oh and welcome,
[-] The following 1 user says Thank You to Johny555 for this post:
  • Jane Rushby
Reply
#3
Hello Jane R from us lot Smile welcome to the forum good to have you with us what motor do you have petrol / Diesel what year we mite be able to help you a with bit more info . Wink
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#4
(22-10-2016, 07:17 PM)Jed Clampit Wrote:  Hello Jane R from us lot Smile welcome to the forum good to have you with us what motor do you have petrol / Diesel what year we mite be able to help you a with bit more info . Wink

Its my dream car, chose it myself and everything, like a 2cv ,but better, with the full electric sunroof.
Er, it is 1.9 diesel W reg, silver. 
Him indoors found it too noisy, slow and uncomfortable for long distances. At the time, he was chauffeuring me about a lot so we ended up using his Rover, which was lovely and comfortable for long distances. Now that I am retiring, not in a hurry, and he gets upset about his clutch slave (sounds weird to me, but everyone to there own) we are using the Blingo again. Result all round, really.
He has changed all the air and fuel filter things and is beginning to grumble (hubby not car) that bits are going to be expensive. To be honest, i think it used to do it before. I call it stuttering, then it surges off again, no rhyme or reason Huh
Reply
#5
How many miles since recommisioning?Have you tried a good brand fuel system cleaner?
Strawberry flavoured windows  Dodgy
Reply
#6
(23-10-2016, 04:20 PM)ron Wrote:  How many miles since recommisioning?Have you tried a good brand fuel system cleaner?

Just clocked over 95000 miles total. He has probably done 20 miles or so going to and from MoT place, filled it up with  new fuel and chucked some fuel system cleaner in but he doesn't know which brand as the label was missing. H thinks it was Wynns. If anything its worse than before. Ticks over nice and quiet , now that he has put the exhaust on properly. Now that it is taxed and legal, I'll have a go and leave him to research EGRs, whatever that is.
Thanks for your help
Reply
#7
Try to give it a decent run whilst the cleaner is in the tank.It works better on a warm engine. After 4 years standing it may have things like piston rings sticking & a goodish rum should help thing come  unstuck.Good luck & keep us informed.
Strawberry flavoured windows  Dodgy
Reply
#8
(25-10-2016, 07:46 PM)ron Wrote:  Try to give it a decent run whilst the cleaner is in the tank.It works better on a warm engine. After 4 years standing it may have things like piston rings sticking & a goodish rum should help thing come  unstuck.Good luck & keep us informed.

Hmmmm, it's not sounding good. It's the hubby on the case now. The beloved and I are in agreement that since the filter change and addition of fuel cleaner the misfire is far worse and more often. Accompanied at times by a nasty clattering noise, from top of engine? Dare not take it out for a  goodish run because it isn't drive able above 20mph 
I'll start a new post with all relevant info elsewhere .
I think I prefer clutch problems on the rover.....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
That question again
Last Post: tommylurvebus
Today 08:12 AM
» Replies: 0
» Views: 22
Clutch cable mounting plate?
Last Post: cancunia
Today 07:31 AM
» Replies: 6
» Views: 520
Missing posts
Last Post: brodfather11
Today 06:05 AM
» Replies: 1
» Views: 214
Radio wiring.
Last Post: brodfather11
Today 06:01 AM
» Replies: 12
» Views: 1687
Dingo - 05 - 2.0 HDI
Last Post: Hardnut
Today 03:49 AM
» Replies: 81
» Views: 17086
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:13 PM
» Replies: 355
» Views: 45712
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:28 PM
» Replies: 52
» Views: 6907
Bypass heater matrix?
Last Post: Zion
Yesterday 09:11 PM
» Replies: 3
» Views: 665
newbie
Last Post: weldore
Yesterday 08:00 PM
» Replies: 2
» Views: 248
Peugeot partner 2.0 hdi 90, will a 406 2.0 hdi 1...
Last Post: Civvic
Yesterday 02:40 PM
» Replies: 1
» Views: 443

[-]
Recent Visitors
Locations of visitors to this page