Thread Rating:
  • 7 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuse Box Problems - BSIE
#1
Hi,

I seem to be having what looks lke a common problem. First the dash lights started playing up, and then the wipers, and now the car will not start.

After looking around on the net, it looks like it will be the fault of the fuse box under the steering wheel.

I've taken it out, and got the following numbers off of it;

BSIE01-00HC
S118085320E

Is there any issue with getting a different one, and then just replacing it - are there any programming issues I need to watch out for?

I managed to track a second hand one down, that has the following number:

S118085320A

The difference only being the last number - any idea if this will work?

Finally, if it does not, does anyone know where I could find a second hand unit?

Thanks alot
Chris

Reply
#2
Hi Chris and thanks for saying hello. Might help to know what type of Berli we're talking about here. Then the guru's can chime in.
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
It may be that all that's needed is for the BSI to be reset/or the firmware re-written.
Authorised Citroen repairers can do this and they're cheaper than main dealers.
Although you'll have to find a garage that have Citroen's Lexia
or the Peugeot equivalent it may still prove to be the cheap option.
I very much suspect that if you were to get a s/h BSI unit it would still need to be set up for your vehicle.
HTH:thumbsup:
The Older I get the Better I Was!  Cool
Reply
#4
Hi,

Thanks for the reponses so far.
it's a 2007 1,4 petrol van

cheers
chris
Reply
#5
Hi Chris.
Who is manufacturer of BSI? Siemens, Valeo?
Reply
#6
Siemens
Reply
#7
Have you tried the BSI reset procedure? It can be found here:

http://www.bba-reman.com/content.aspx?co...ol_failure

Worth a shot??
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#8
Does any aftermarket alarm system installed in your car?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:49 PM
» Replies: 687
» Views: 151124
One brake light working
Last Post: dumdum
Yesterday 11:36 AM
» Replies: 11
» Views: 946
Rear Hub Nut Size
Last Post: ntm1275
24-03-2019 11:06 PM
» Replies: 4
» Views: 929
Engine noise
Last Post: cancunia
24-03-2019 05:01 PM
» Replies: 31
» Views: 14502
Cruise control (again), yes again, but working (...
Last Post: cancunia
23-03-2019 01:24 PM
» Replies: 101
» Views: 15744
2003 2.0 HDI Poor fuel consumption
Last Post: Trevor
23-03-2019 12:38 PM
» Replies: 34
» Views: 10359
puff of blue-ish smoke on startup
Last Post: Art b
22-03-2019 10:37 PM
» Replies: 12
» Views: 1506
Speedo / Instrument Cluster Removal
Last Post: cancunia
22-03-2019 04:05 PM
» Replies: 2
» Views: 400
airbag stolen - is it a thing
Last Post: rapidyellow
22-03-2019 10:39 AM
» Replies: 3
» Views: 837
EGR valve
Last Post: cancunia
22-03-2019 10:19 AM
» Replies: 1
» Views: 224

[-]
Recent Visitors
Locations of visitors to this page