Thread Rating:
  • 24 Vote(s) - 2.42 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lexia 3 Air bag light Help.
#1
[/font]Hi to all.
I recenctly purchased an 06 Berlingo 2.0Hdi van with the air bag light lit on the dash. So did the usual seat connections and steering one which all seemed ok. It still remained lit.
So I invested in a lexia 3 unit of ebay to see if that would point me in the right direction. The software installed and updates were succesful. Can any one tell me why this doesn't seem to be connecting to the ecu to read the codes? It goes through the scan but doesn't pick up any faults. Does the unit have to be configured or am I just not doing it right? Has anyone managed to get these units working on an 06 plate vans?
Cheers.
2006 2.0hdi 600 with bench seat.  Cool
Reply
#2
I'm still fumbling with mine on a MK3. I was cautioned by a very knowledgeable member of this forum not to mess with airbag settings unless you really know what you're doing. Can lead to surprises.
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
(12-10-2011, 02:38 PM)Rustscrat Wrote:  [/font]Hi to all.
I recenctly purchased an 06 Berlingo 2.0Hdi van with the air bag light lit on the dash. So did the usual seat connections and steering one which all seemed ok. It still remained lit.
So I invested in a lexia 3 unit of ebay to see if that would point me in the right direction. The software installed and updates were succesful. Can any one tell me why this doesn't seem to be connecting to the ecu to read the codes? It goes through the scan but doesn't pick up any faults. Does the unit have to be configured or am I just not doing it right? Has anyone managed to get these units working on an 06 plate vans?
Cheers.
Lexia works on all PSA cars. If it's not work this can be:
1. Updates with bugs.
2. Inside plastic box is not Lexia.

Go to "Airbag" menu and read errors. Only read and that's all!!!
Otherwise, you'll know how airbag works SmileBig Grin

Reply
#4
Thanks for the warnings - The problem for the minute though is that I can't get the unit to comm with the ecu. Have tried with the "scantool" but this again comes up with "No dialogue with ECU during initialisation"
Any idea's?
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
See item 1 in a previous post
Reply
#6
Yeah, with scantool I get the same error. With the Lexia choice it tells me that the ECU is unrecognized and that the value may not be valid. Right now reviving my schleptop.
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#7
(12-10-2011, 05:44 PM)Rustscrat Wrote:  Thanks for the warnings - The problem for the minuite though is that I can't get the unit to comm with the ecu. Have tried with the "scantool" but this again comes up with "No dialogue with ECU during initialisation"
Any idea's?

From the same experiance as you when setting up Lexia do the following:
1, Check all your fuse`s in both BSI and BSM- Replace any failed fuse`s .
2, Do a BSI reset then have another go with Lexia.

2003 Citroën Berlingo 2.0HDi Multispace Desire
Reply
#8
Thanks for *ALL* advice fella's - Will try tomorrow and let you know what happens.
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
Checked all fuses and connections in bsi & bsm modules - all ok. Still getting "No dialogue with ECU during initialisation". Starting to wonder if the bsi unit is U/S. Might strip it out and check as it looks like thers's liquid spillage from the top of the dash.
Anybody know what would not work if this is the case ???

Thanks.
2006 2.0hdi 600 with bench seat.  Cool
Reply
#10
(13-10-2011, 05:58 PM)Rustscrat Wrote:  Checked all fuses and connections in bsi & bsm modules - all ok. Still getting "No dialogue with ECU during initialisation". Starting to wonder if the bsi unit is U/S. Might strip it out and check as it looks like thers's liquid spillage from the top of the dash.
Anybody know what would not work if this is the case ???

Thanks.

Did you read my pm regards Lexia updates ?

2003 Citroën Berlingo 2.0HDi Multispace Desire
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Snow Tyres
Last Post: Gollycrush
Yesterday 09:32 PM
» Replies: 0
» Views: 118
EML light on - No Fault Code
Last Post: TONX
Yesterday 08:05 PM
» Replies: 0
» Views: 138
No Click from Solenoid
Last Post: Zweli
Yesterday 07:46 PM
» Replies: 0
» Views: 125
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Yesterday 07:11 PM
» Replies: 24
» Views: 8805
What website to pass time over a winters evening...
Last Post: josegar
Yesterday 05:05 PM
» Replies: 5
» Views: 2644
Headlight adjustment
Last Post: Sophiante
Yesterday 05:02 PM
» Replies: 2
» Views: 562
Hi from a me and what to do.
Last Post: cancunia
Yesterday 04:49 PM
» Replies: 3
» Views: 273
2004 alternator not charging
Last Post: Art b
Yesterday 10:58 AM
» Replies: 3
» Views: 611
AUX install for radio
Last Post: ntm1275
22-09-2018 10:17 PM
» Replies: 3
» Views: 797
Lowering springs
Last Post: DMaclean
22-09-2018 07:28 PM
» Replies: 0
» Views: 329

[-]
Recent Visitors
Locations of visitors to this page