Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Electrical connections of what ?
#1
Hi all...

A niggly fault has recently occurred, and is driving me insane... While the car starts with no problem, runs with no loss of power, and to date all electrical equipment seems to operate perfectly, intermittently the relays click under the dash, the dash lights go brighter, as do the headlamps in line with the clicking from the relay, and the A/C fan will sometimes start though the A/C is not turned on, this coincides with the small flashing red light in the temp gauge display (A/C on)

I have taken it to our local dealer who basically just fobs us off with excuses, this is Bulgaria, so if it cannot be repaired with a big hammer, it cannot be repaired....

I have made some inquiries and came up with the possibility that it could be corrosion in a connector, possibly causing a bad earth ? but fail to see how this could be making the headlamps flicker brighter ? (this is causing me great embarrassment as it looks like i am flashing other cars, not desirable when they are huge black Mercs being driven by mafia meatheads)

If anyone has any ideas it would really be appreciated

Steve

ps. It is a 2003 MPV 2.0 HDI
Reply
#2
(09-11-2016, 06:21 PM)SteveC Wrote:  Hi all...

A niggly fault has recently occurred, and is driving me insane... While the car starts with no problem, runs with no loss of power, and to date all electrical equipment seems to operate perfectly, intermittently the relays click under the dash, the dash lights go brighter, as do the headlamps in line with the clicking from the relay, and the A/C fan will sometimes start though the A/C is not turned on, this coincides with the small flashing red light in the temp gauge display (A/C on)

I have taken it to our local dealer who basically just fobs us off with excuses, this is Bulgaria, so if it cannot be repaired with a big hammer, it cannot be repaired....

I have made some inquiries and came up with the possibility that it could be corrosion in a connector, possibly causing a bad earth ? but fail to see how this could be making the headlamps flicker brighter ? (this is causing me great embarrassment as it looks like i am flashing other cars, not desirable when they are huge black Mercs being driven by mafia meatheads)

If anyone has any ideas it would really be appreciated

Steve

ps. It is a 2003 MPV 2.0 HDI

Check for water damage to BSI unit. 
That year is known for that. Use search on forum to
find similar posts.

Best regards,
brajomobil
Reply
#3
(10-11-2016, 08:28 AM)brajomobil Wrote:  
(09-11-2016, 06:21 PM)SteveC Wrote:  Hi all...

A niggly fault has recently occurred, and is driving me insane... While the car starts with no problem, runs with no loss of power, and to date all electrical equipment seems to operate perfectly, intermittently the relays click under the dash, the dash lights go brighter, as do the headlamps in line with the clicking from the relay, and the A/C fan will sometimes start though the A/C is not turned on, this coincides with the small flashing red light in the temp gauge display (A/C on)

I have taken it to our local dealer who basically just fobs us off with excuses, this is Bulgaria, so if it cannot be repaired with a big hammer, it cannot be repaired....

I have made some inquiries and came up with the possibility that it could be corrosion in a connector, possibly causing a bad earth ? but fail to see how this could be making the headlamps flicker brighter ? (this is causing me great embarrassment as it looks like i am flashing other cars, not desirable when they are huge black Mercs being driven by mafia meatheads)

If anyone has any ideas it would really be appreciated

Steve

ps. It is a 2003 MPV 2.0 HDI

Check for water damage to BSI unit. 
That year is known for that. Use search on forum to
find similar posts.

Best regards,
brajomobil


Thank you my friend, will check it out
Reply
#4
Could be a lose earth wire,have you checked battery?
Reply
#5
(10-11-2016, 06:20 PM)Johny555 Wrote:  Could be a lose earth wire,have you checked battery?

I was thinking that was a likely reason, especially as the dash and headlights flicker brighter, but i'm more inclined to think it's a poor earth connection in a block connector... i had checked the most obvious connections and everything seemed ok. What would be helpful is the location of connectors ? and what problems may occur if i disconnect them in order to check... i am referring to the BSI, would powering down (disconnect battery) be adequate ? or would there need to be a procedure ?
Reply
#6
I wonder where the V-reg is on these, in the alternator, or elsewhere?

Needs fixing before the (likely) excess voltage, that sounds like is occurring, damages summat more expensive than a bulb or 2 (but I know that you know that Blush )
Regards to all,
John - (2005 2.0HDi with Modutop roof, mini camper).



Reply
#7
(13-11-2016, 09:13 AM)ghost123uk Wrote:  I wonder where the V-reg is on these, in the alternator, or elsewhere?

Needs fixing before the (likely) excess voltage, that sounds like is occurring, damages summat more expensive than a bulb or 2 (but I know that you know that Blush )

Must confess that i had not thought of this, seems plausible as well... will check
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
reversing mirrors
Last Post: frank
Today 03:36 PM
» Replies: 2
» Views: 345
Persistent EML - P0170 P40 - Help / Info needed
Last Post: rublehousen
Today 02:23 PM
» Replies: 1
» Views: 105
Dealers ..Pahh
Last Post: nikita123
Today 11:44 AM
» Replies: 12
» Views: 6585
Highest mileage Berlingos
Last Post: Brico
Today 11:30 AM
» Replies: 30
» Views: 8951
gearbox removal
Last Post: Brico
Today 11:21 AM
» Replies: 3
» Views: 387
Berlingo sudden lurching and jumping.
Last Post: ffrenchie
Today 09:08 AM
» Replies: 8
» Views: 1144
Big miles on an auto!??
Last Post: manovilla
Today 07:26 AM
» Replies: 23
» Views: 3366
New Vauxhall (Berlingo)
Last Post: manovilla
Today 07:20 AM
» Replies: 11
» Views: 1142
What Reg Berlingo do you own?
Last Post: manovilla
Today 07:17 AM
» Replies: 128
» Views: 83985
gear leaver and rod needed
Last Post: landcrab
Yesterday 11:01 PM
» Replies: 2
» Views: 286

[-]
Recent Visitors
Locations of visitors to this page