Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.0 HDi fuel issues as per **update
#1
Hi all wondering if any one has any input on my issues,
I have a 2001 HDi berlingo, bought it with EML on giving P0230. It ran fine no issues at 1st, it conked out on motorway with me after a few days with quater a tank showing but turns out after a gallon of fuel thrown in she came to life and for a couple days it ran on and off limp mode restricting power and now and then it would cut out randomly, when eml on you can turn off and take key out it would continue to run for a second or two.
Now i replaced the fuel filter and filled the tank it ran spot on no lights and no issues, until yesterday i drove home and then it wouldnt start again, the lift pump is not coming on with ignition but i can here a relay clicking some were when ignition is turned on, just no fuel pump, no fuel reaching the filter either. Its deffo the lift pump not coming on and the "stop" light is on dash. Is there any thing to check before i go for lift pump as its a tank out job and not something i look forward to as vans parked on a main road


Sent from my iPhone using Tapatalk
Reply
#2
Fuses and Relay first, then wiring and finally pump
Reply
#3
Col can you direct me to the relay, i was told behind battery but there is ecu and behind it is a black box with lives going in. As for the fuse i have tried to make sense of the fuse box and find a guid as to what fuse goes were but no joy the index i could find on google had no fuse in the 1 described as fuel pump?


Sent from my iPhone using Tapatalk
Reply
#4
there is a fuse in the engine fuse box F25 according to my h/book.

According to Haynes there is only a lift pump if you have a Bosch system.
Reply
#5
I was searching for a switch for my Berlingo when I came across this about a relay in the fuse box.

" VARIOUS APPLICATIONS

COMMONLY CONTROLS AIR CONDITIONING AND MORE IMPORTANTLY THE FUEL PUMP DELIVERY. FAILURE CAN OCCUR RENDERING THE VEHICLE IMMOBILE. THE CAR WILL TURN OVER BUT NOT FIRE.
TRY SWAPPING THE AIR CON RELAY WITH THE FUEL PUMP CONTROL RELAY. IF SHE FIRES, YOU'VE CRACKED IT. "

It would be worth trying IF you have air con., would rule out a dodgy relay
Reply
#6
Hi no it doesnt have air conditioning, and yes im sure its bosch R65 pump being the 90bhp model and all fuses in engine compartment are intact. Thanks for replies. Its pointing more and more to lift pump but i know what hdi is like and too many sensors everywere one of them could be preventing the pump from lifting, without dropping tank i need a way to check the suply to that pump and see if power is being sent from the front to the back because if not, then no point to drop tank. On one attempt to try start it yesterday i got a yellow key warning light and a beep, but quick flash and not been back on again. Tried a bsi reset to no avail as no central locking maybe it has no effect


Sent from my iPhone using Tapatalk
Reply
#7
So now i have an update!

Taken tank out, ran a direct live and earth to the pump and nothing.... so new pump in, rigged back up.. filled with fuel and hey presto it runs! So i head out after clearing the codes and its off like a bullet. Eml comes on it drops into limp mode (2krpm) and when you let off accelerator it cuts out wether in gear or not, u have to take the key out, and back in to restart it.. even if you clear the codes, instantly back in limp mode and will cut out when you let off


Sent from my iPhone using Tapatalk
Reply
#8
Did you check fuel pressure sensor ?
On the side of the HP pump.
It is common problem for 2.0 hdi.

You can take it off and clean. Carb cleaner. 
Replace orings.

If it helps then you need to buy new one.


Best regards,
brajomobil
Reply
#9
This may be of interest:

https://www.pug306.net/forum/archive/ind...41654.html
Reply
#10
Thanks, i will go take the fpr out now and clean it up. See if this works. Will update later today


Sent from my iPhone using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Today 06:29 PM
» Replies: 11
» Views: 7185
AUX install for radio
Last Post: Peter Palmer
Today 06:23 PM
» Replies: 1
» Views: 206
Another Newbie
Last Post: Tomcat3
Today 06:15 PM
» Replies: 1
» Views: 17
handbrake travel and wheels fitment
Last Post: jj9
Today 06:09 PM
» Replies: 8
» Views: 917
Windscreen Arm Linkage keeps Popping Off
Last Post: Jayfranco
Today 06:05 PM
» Replies: 2
» Views: 22
Alternator not charging no 12v at small purple w...
Last Post: Art b
Today 01:30 PM
» Replies: 4
» Views: 13426
2004 alternator not charging
Last Post: frank
Today 01:28 PM
» Replies: 1
» Views: 110
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gravity
Today 01:09 PM
» Replies: 10
» Views: 4105
Central locking problem
Last Post: srcomp
Today 12:43 PM
» Replies: 0
» Views: 67
rear axle mot failure
Last Post: jj9
Today 09:51 AM
» Replies: 3
» Views: 421

[-]
Recent Visitors
Locations of visitors to this page