Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Display screen fault
#1
Hi all I've got a 2014 citroen berlingo van. My display screen for radio etc has turned orange and doesn't display anything it's just orange all the time but the radio still works and my Bluetooth for phone still work, but even when the keys are out the ignition the screen is still bright orange. Any help on this would be great thanks


Attached Files Thumbnail(s)
   
Reply
#2
Disconnecting the battery should fix it,same thing happened to my brother in laws. Cheers
Reply
#3
Thanks robfitzi will try it. Do I need a radio code to put back in the radio to get it working again
Reply
#4
We didn't need one when we did it I think just need to reset the stations
Reply
#5
The radio is coded to the car so you should have no problem.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
That question again
Last Post: tommylurvebus
Today 08:49 PM
» Replies: 2
» Views: 192
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:21 PM
» Replies: 356
» Views: 45907
Camper Cushion Fabric
Last Post: Tomcat3
Today 08:01 PM
» Replies: 1
» Views: 34
Radio wiring.
Last Post: Zion
Today 04:42 PM
» Replies: 13
» Views: 1896
Clutch cable mounting plate?
Last Post: cancunia
Today 07:31 AM
» Replies: 6
» Views: 632
Missing posts
Last Post: brodfather11
Today 06:05 AM
» Replies: 1
» Views: 313
Dingo - 05 - 2.0 HDI
Last Post: Hardnut
Today 03:49 AM
» Replies: 81
» Views: 17362
1.6 hdi lumpy cold start
Last Post: Zion
Yesterday 09:28 PM
» Replies: 52
» Views: 7139
Bypass heater matrix?
Last Post: Zion
Yesterday 09:11 PM
» Replies: 3
» Views: 714
newbie
Last Post: weldore
Yesterday 08:00 PM
» Replies: 2
» Views: 297

[-]
Recent Visitors
Locations of visitors to this page