Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EML - EGR at fault
#1
The EML on my 2011 VTR came on and stayed on just before the MoT. Despite this my Citroen agent passed it but diagnosed it with EGR failure And to fix it at £855.60! Asvthe engine performed well, In desperation I tried Wynn's EGR spray cleaner at £10.00 and disconnected the battery overnight and hey presto the lamp now goes out when it should. Worth a try! Big Grin
Reply
#2
Hi thats a stroke ok luck, i doubt the EGR cleaner had any effect, i suspect the battery disconnected for that long has allowed the EML to reset?

you will just have to see if it comes back on - im afraid my money is yes it will.

O and hi and welcome to the forum
[-] The following 1 user says Thank You to polar for this post:
  • MarkT
Reply
#3
Prices have risen. My Cit garage charged £550 to replace an egr valve about 4yrs ago. The egr valve flap had actually snapped off inside. Car would only run in limp mode so had to be done. When mine failed I had 'antipollution fault' come up on the screen though. If you do need a replacement avoid using cheap parts that could be substandard. You need to use genuine OEM part made by Valeo.
Reply
#4
I'm with you in your belief,but tried the cleaner as an act of desperation. It's odd that the engine runs fine and the EML light never lit up when the car was going down the road, only on start up?. I've done a few hundred miles and many starts without problem, but I'm fed up with staring at the lamp, so reckon it's time to get rid of the car while the goings good. Thanks for the heads up with the replacement parts tip.
Reply
#5
Update on EGR valve deemed faulty. Last year's MoT the EGR was deemed faulty and required replacing at great expense. In desperation I tried a EGR cleaner and disconnected the battery for 24 hours. Since then the EML has behaved as it should. Still not convinced I dreaded this year's MoT, but a diagnostic check has revealed no fault with the valve! Not sure if this trick paid off, but since the last MoT I've only used BP Ultimate, although more expensive it might actually lived up to its claim that it cleans the engine. It appears to my car that the use of 'snake oil' technology has worked until the next time!
[-] The following 1 user says Thank You to TioPotz for this post:
  • polar
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Winter tyres c/w steel wheels
Last Post: StuBeeDoo
Today 02:40 PM
» Replies: 1
» Views: 411
CAT/DPF removal - can it be pulled out upwards?
Last Post: GraemeT
Today 02:10 PM
» Replies: 0
» Views: 12
Six weeks in...New Berlingo van.
Last Post: Tree
Today 12:34 PM
» Replies: 2
» Views: 90
New Berlingo owners - are they any good?
Last Post: Tree
Today 12:33 PM
» Replies: 9
» Views: 991
Amdro Boot Jump with for Sale
Last Post: Ginny
Today 11:48 AM
» Replies: 0
» Views: 46
Bad throw out bearing at idle?
Last Post: ArozNick
Today 10:40 AM
» Replies: 2
» Views: 361
1.6 Blue HDi 100 Engine appear to be burning oil
Last Post: jj9
Today 09:46 AM
» Replies: 13
» Views: 1163
2018 Berlingo Radio Won't Switch Off.
Last Post: Alan22
Today 09:38 AM
» Replies: 9
» Views: 5309
P0234 code fault
Last Post: Higgsy
Today 07:39 AM
» Replies: 2
» Views: 259
2010 1.6L HDI berlingo SOMETIMES wont start
Last Post: Tomcat3
Today 06:44 AM
» Replies: 7
» Views: 467

[-]
Recent Visitors
Locations of visitors to this page