Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2010 1.6hdi - speedo fault
#1
Just picked up a Berlingo 1.6 HDI, stupidly on test drive I didn't notice the speedo wasn't working and parted with my cash so now I'm stuck with a faulty speedo. 

Anyway I'm hoping you guys can help me, the rest of the binnacle is working fine other than the speedo and the milagage/ trip computer. 

I suspect it being a sensor but no idea where it's located and how to diagnose that's definitely the problem. 

Any info is much appreciated.
Reply
#2
Probably faulty sensor. 
You can use "search" forum function and you will find answer in 15 min.

Best regards,
brajomobil
Reply
#3
So a little update. I found the location of the speedo drive sensor (at the back of the gearbox just in front of the gear linkage rods if anyone is interested)
Replaced the old part with a new one and the speedo still isn't working.
I've checked the drive gear inside the gearbox and that moves when the wheels rotate but for some reason I'm not getting a reading on the speedo.
Had the van to the local auto electrician who had it in a Bosch computer but couldn't find any faults. I tried attaching the speedo drive to a drill and spinning it to see if the speedo registered anything but no joy.
Starting to think there's a problem in the wiring loom.

Getting really frustrated now.
Reply
#4
Your best bet would be connecting it up to the citroen/Peugeot Lexia software and look for faults. There may be a member near you with the software who could help for beer tokens or have a look on French car forum and check out their map for Lexia user near you.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#5
Uh, then you will need to check wires from sensor to BSI.

If you need schematic , shout.

Best regards,
brajomobil
[-] The following 1 user says Thank You to brajomobil for this post:
  • Bradjohnson
Reply
#6
Schematic would be brilliant if you have it.

Kind regards.
Reply
#7
Tacho, speed sensor is number 1620 on pdf page1


You have 3 wires to check
Wire 1
pin1 CM01D goes to connector 16v NR pin 2
16v NR connector is on PSF1 fuise box PDF page3  "A" picture


Wire 2
pin2 M162 goes to GROUND
Easy to check with ommmethar


Wire 3
pin3 7638  goes to connector 48V MR pin B3
48V MR connecor is on engine ECU PDF page3 "F" picture


.pdf   berlingo_speed_sensor_page1.pdf (Size: 444.21 KB / Downloads: 44)

.pdf   berlingo_speed_sensor_page2.pdf (Size: 578.63 KB / Downloads: 32)

.pdf   berlingo_speed_sensor_page3.pdf (Size: 473.01 KB / Downloads: 39)

Best regards,
brajomobil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
An alternative to Diagbox - Topdon Artidiag 800B...
Last Post: Antdad
Today 04:29 AM
» Replies: 11
» Views: 326
Thule Spirit 820 Roofbox
Last Post: Antdad
Today 04:10 AM
» Replies: 1
» Views: 83
Identifying Electrical Fault :-( Work Around Adv...
Last Post: shtu
Yesterday 10:26 PM
» Replies: 1
» Views: 41
Grey smoke
Last Post: shtu
Yesterday 10:19 PM
» Replies: 21
» Views: 620
My K9 Upgrade
Last Post: chrisl
Yesterday 09:17 PM
» Replies: 4
» Views: 474
OBD Red discussion
Last Post: csrote
Yesterday 06:32 PM
» Replies: 75
» Views: 5134
Diagbox/lexia 3, which one?
Last Post: Antdad
Yesterday 06:32 PM
» Replies: 2
» Views: 42
As I've now disabled my start stop
Last Post: Pat888
Yesterday 05:54 PM
» Replies: 8
» Views: 218
Total beginner to obd2, cables, hardware and sof...
Last Post: Antdad
Yesterday 10:57 AM
» Replies: 3
» Views: 93
1.5 Blue HDi info: oil and chain
Last Post: 5EAN
Yesterday 09:07 AM
» Replies: 28
» Views: 14202

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK