Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Knocking from the frond end
#1
Hello,

I have tried to fix a knocking sound in the front end by changing the anti roll bar drop links, control arm bushings, and the lower ball joints. Still no luck, I now wonder if changing the top strut mountings can help?

Would this kit be enough?

http://www.ebay.com/itm/SWAG-62-92-2131-...SwoBtW6ulQ
Reply
#2
Also check your springs one might of snaped
Reply
#3
Have the same problem on the left hand side on my 2011 VTR and my previous M59. Citroen agent unable to find fault. On both cars drop links changed, the first was fitted by a garage at £75.00 and the knock never came back, but my VTR only worked for the first 5k miles, but cost only £20.00, obviously a cheap part? Only knocks over very rough surfaces, which means most UK roads. Very annoying!
Reply
#4
Just had my front spring replaced after it snapped. However, it had been snapped higher up for ages and I was unaware and thought the odd rattle would be the drop links.

The earlier snap had rusted up. So could be the spring but not easy to see the break.
Reply
#5
I will have a closer look on the springs. Does anyone know if the kit i linked to is the correct one?
Reply
#6
Some top mount's fit better than other's some stop the knocking for a short time then it comes back other don't .
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#7
The top mounts only knock if the centre bush has noticeably deteriorated , I am seeming to find it's generally the damper that is faulty, but you cannot see any fault with it on inspection.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Looking for a B9 with Modutop
Last Post: ron
Yesterday 08:30 PM
» Replies: 1
» Views: 106
COFUSED .COM
Last Post: polar
Yesterday 08:19 PM
» Replies: 4
» Views: 257
Hand Priming Pump
Last Post: Lighty
Yesterday 08:09 PM
» Replies: 5
» Views: 415
Speedo binnacle fault
Last Post: cancunia
Yesterday 07:01 PM
» Replies: 1
» Views: 106
mountings
Last Post: bikey
Yesterday 01:31 PM
» Replies: 2
» Views: 261
Adding seats to the back
Last Post: TheCraftyCarpenter
Yesterday 12:12 PM
» Replies: 2
» Views: 518
1.6 Blue HDi 100 Engine appear to be burning oil
Last Post: geoff
Yesterday 12:02 PM
» Replies: 17
» Views: 1966
Front brake caliper retaining bolts
Last Post: geoff
19-10-2019 09:52 PM
» Replies: 5
» Views: 466
Bad throw out bearing at idle?
Last Post: geoff
19-10-2019 08:01 PM
» Replies: 6
» Views: 729
non start
Last Post: carl222
19-10-2019 07:29 PM
» Replies: 3
» Views: 185

[-]
Recent Visitors
Locations of visitors to this page