Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Immobilized? ECU? Bad Earth? Gremlins?
#1
Just bought a 55 plate 1.9D multispace for Spain's or repair.

The nice lady told me she had spent 300 quid on "something to do with fuel pump"then all this weird stuff started to happen and her garage told her it was the immobilsel, 800£ please .
This was a couple of months ago. She pre charged battery and then disconnected it as the Cobra alarm siren kept sounding, reinforcing the immobilized theory, along with flashing indicators. 

Anyway, got it home and put a decent battery on, low and behold starts first time, no siren or flashing lights therefore can't be immobilized..,,

However has exactly same symptoms as 2 other posts that I've commented on and yet to be resolved 

Symptoms include...no headlights 
Flash but not main beam
Only half of dash warning lights work, then it all goes dead after half a minute or so.
No windscreen wipers 
No heater fan
No speedo
No rev counter
Eco mode on display screen 
Indicators work but not the warning lights on dash

I have only recently arrived in the 21st century so all this electrickery stuff is beyond my pay scale and experience.

Hoping it is a really common and simple fix, please tell me it is?
Reply
#2
Have you tried a BSI reset?
[-] The following 1 user says Thank You to V6BOY for this post:
  • ian432
Reply
#3
(22-05-2017, 10:12 AM)V6BOY Wrote:  Have you tried a BSI reset?

Thanks for reply.....not yet, just looked up what that involves and I think I can manage that ?

Nice logical steps, is what I like, first of many by previous experience.....
Reply
#4
Definitely sounds like BSI related problems hopefully if your lucky the BSI reset will do the trick.
[-] The following 1 user says Thank You to V6BOY for this post:
  • ian432
Reply
#5
Gave it a couple of goes over last few daze but no change...back to the drawing board, I guess ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Injector/Cam Larder Studs 1.6 HDI
Last Post: saskak
Today 01:07 PM
» Replies: 52
» Views: 8220
Engine noise
Last Post: cancunia
Yesterday 10:03 AM
» Replies: 21
» Views: 5342
clutch pedal
Last Post: ffrenchie
20-02-2019 08:06 AM
» Replies: 9
» Views: 2258
tensioner pulley
Last Post: RJBingham
17-02-2019 07:18 PM
» Replies: 19
» Views: 4034
Eberspacher or similar
Last Post: David Edwards
15-02-2019 01:10 PM
» Replies: 13
» Views: 3953
Overheat and antipollution?
Last Post: mikeB
15-02-2019 11:39 AM
» Replies: 26
» Views: 7341
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
14-02-2019 10:04 PM
» Replies: 651
» Views: 136928
Valves DW8
Last Post: Arbe
13-02-2019 11:11 AM
» Replies: 51
» Views: 11356
throttle cable - where to get a good one.
Last Post: Arbe
12-02-2019 05:35 PM
» Replies: 9
» Views: 2761
2003 2.0 HDI Poor fuel consumption
Last Post: ffrenchie
12-02-2019 04:23 PM
» Replies: 31
» Views: 8181

[-]
Recent Visitors
Locations of visitors to this page