Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Terrible radio reception
#1
Is this a common fault? I'm on my 2nd van of the same year and model (2012) now and they both did it. Its like the aerial isn't connected. I struggle to pick up local radio stations
Fire bad, tree pretty
Reply
#2
(10-06-2017, 02:34 PM)Kez Wrote:  Is this a common fault? I'm on my 2nd van of the same year and model (2012) now and they both did it. Its like the aerial isn't connected. I struggle to pick up local radio stations

Hi Kez

I'll kick off the thread ..... exactly same here on a 2010 saloon model, lets see what the rest of the forum say

cheers
Reply
#3
Do you have a USB adaptor plugged into the 12 volt cigarette socket ?  If so, try removing it.
Some of these adaptors are poorly designed and radiate hash all over radio spectrum, giving exactly your symptoms.
[-] The following 2 users say Thank You to nicko for this post:
  • Kez, Matt Haigh
Reply
#4
or do as i do never switch it on ;-)
Reply
#5
I have a 98 M49 and the reception was awful on the original head unit. When I got round to replacing the HU I also looked at the aerial connection above the shelf and was surprised to find that the car had two aerial cables - one wasn't connected to the antenna! At the head unit end the two wires had the different aerial standard connectors (one ISO banana, the other DIN) and the one I was using was not the one attached to the aerial.
Obviously a lot has changed from 98 to the B9 but the French are still French. Maybe check at the antenna connection in the roof?
Reply
#6
The original radio RD4 or similar is regular, not very good, but the problem is the speakers. They are very bad and with year after year the sound is worst.

The best option is upgrade the speakers before the unit radio. This is a big gap. Big Grin
Vigo, The cradle of all Berlingos / Partners.  Big Grin Heart
Reply
#7
Oh I'm going to change the speakers.. but this problem is signal related. I do have a usb converter, so will give that a try
Fire bad, tree pretty
Reply
#8
I have a Myway Rneg radio and the reception is also poor in fact I think the RD4 was better plus is has more pre-sets. I agree with ”Nicko”  a USB connection can cause problems I have two Dash Cams one with no problem the other I do,  so I have ordered some small clip on RFI Noise Ferrite filters hoping this will resolve the problem plus fitting a VW aerial amplifier
Reply
#9
(10-06-2017, 06:20 PM)nicko Wrote:  Do you have a USB adaptor plugged into the 12 volt cigarette socket ?  If so, try removing it.
Some of these adaptors are poorly designed and radiate hash all over radio spectrum, giving exactly your symptoms.


Brilliant advice, thank you. Thats exactly what the problem was
Fire bad, tree pretty
Reply
#10
Yay.. Glad its sorted Cool

Nick.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Injector/Cam Larder Studs 1.6 HDI
Last Post: saskak
Today 01:07 PM
» Replies: 52
» Views: 8217
Engine noise
Last Post: cancunia
Yesterday 10:03 AM
» Replies: 21
» Views: 5340
clutch pedal
Last Post: ffrenchie
20-02-2019 08:06 AM
» Replies: 9
» Views: 2258
tensioner pulley
Last Post: RJBingham
17-02-2019 07:18 PM
» Replies: 19
» Views: 4034
Eberspacher or similar
Last Post: David Edwards
15-02-2019 01:10 PM
» Replies: 13
» Views: 3953
Overheat and antipollution?
Last Post: mikeB
15-02-2019 11:39 AM
» Replies: 26
» Views: 7341
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
14-02-2019 10:04 PM
» Replies: 651
» Views: 136927
Valves DW8
Last Post: Arbe
13-02-2019 11:11 AM
» Replies: 51
» Views: 11356
throttle cable - where to get a good one.
Last Post: Arbe
12-02-2019 05:35 PM
» Replies: 9
» Views: 2761
2003 2.0 HDI Poor fuel consumption
Last Post: ffrenchie
12-02-2019 04:23 PM
» Replies: 31
» Views: 8181

[-]
Recent Visitors
Locations of visitors to this page