Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] injector seals
#1
my berlingo 2004  2.0 hdi  went into garage today to have new injector seals fitted. only number 3 seal was blowing but  mech said it would be best to get a new set of 4 done while i was at it.i got the seals from europart for £10.85 the set. i dont know if it was just me but it do seem to pull better (although it was never slow ) ive had the car for over 5 yrs now and the air con has never worked,and with the heat we have had latley i ask him to re gas it at the same time.i wasnt sure it would be ok after all this time...WOW! what a joy to drive now freezing cold air.[Image: cool.png] i didnt want to stop driving...i wish i had it done 5 years ago.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Unorthodox methods
Last Post: Peter Palmer
Today 10:00 AM
» Replies: 4
» Views: 261
Front wipers not working
Last Post: ffrenchie
Today 06:46 AM
» Replies: 4
» Views: 480
Weird fan like noise from engine on 1.6 Blue HDi...
Last Post: kingy1912
Yesterday 09:26 PM
» Replies: 2
» Views: 424
Suspension knock
Last Post: labeline
Yesterday 08:46 PM
» Replies: 2
» Views: 246
Towing weight
Last Post: Trevor
Yesterday 06:36 PM
» Replies: 14
» Views: 2957
Another air con problem
Last Post: Peter Palmer
Yesterday 03:05 PM
» Replies: 11
» Views: 2054
Not another Aircon thread
Last Post: Peter Palmer
Yesterday 02:54 PM
» Replies: 2
» Views: 199
random hesitation (increasing frequency) and ESP...
Last Post: Bootlebarth
Yesterday 11:17 AM
» Replies: 0
» Views: 222
battery drains overnight
Last Post: Art b
Yesterday 11:06 AM
» Replies: 20
» Views: 4657
hello all
Last Post: Gadgetman
Yesterday 05:36 AM
» Replies: 7
» Views: 767

[-]
Recent Visitors
Locations of visitors to this page