Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
oil presure warning
#1
HI ALL IM HAVING A BIT OF TROUBLE WITH MY 2008 BERLINGO ITS ON THE XOVER BUT THE MODEL PREVIOUS IF THAT MAKES SENSE I HAVE DONE AN OIL CHANGE AND FILTER CHANGE ALL LEVELS CORRECT BUT WHEN DRIVING NO WARNING STRAIGHT OR TURNING LEFT BUT TOUCH THE WHEEL TO TURN RIGHT THE OIL LIGHT COMES ON AS WELL AS THE STOP LIGHT 

PLEASE HELP

THANKS IN ADVANCE
Reply
#2
Hi and welcome CPH
Reply
#3
CHEERS AND HI BACK ANY IDEA ON MY PROBLEM
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Winter tyres c/w steel wheels
Last Post: StuBeeDoo
Today 02:40 PM
» Replies: 1
» Views: 411
CAT/DPF removal - can it be pulled out upwards?
Last Post: GraemeT
Today 02:10 PM
» Replies: 0
» Views: 12
Six weeks in...New Berlingo van.
Last Post: Tree
Today 12:34 PM
» Replies: 2
» Views: 90
New Berlingo owners - are they any good?
Last Post: Tree
Today 12:33 PM
» Replies: 9
» Views: 991
Amdro Boot Jump with for Sale
Last Post: Ginny
Today 11:48 AM
» Replies: 0
» Views: 46
Bad throw out bearing at idle?
Last Post: ArozNick
Today 10:40 AM
» Replies: 2
» Views: 362
1.6 Blue HDi 100 Engine appear to be burning oil
Last Post: jj9
Today 09:46 AM
» Replies: 13
» Views: 1163
2018 Berlingo Radio Won't Switch Off.
Last Post: Alan22
Today 09:38 AM
» Replies: 9
» Views: 5309
P0234 code fault
Last Post: Higgsy
Today 07:39 AM
» Replies: 2
» Views: 259
2010 1.6L HDI berlingo SOMETIMES wont start
Last Post: Tomcat3
Today 06:44 AM
» Replies: 7
» Views: 467

[-]
Recent Visitors
Locations of visitors to this page