Engine Misfire / Power Issue and Engine Noise
#1
Sad 
Help!!! Berlingo Multispace 1.9D
Driving to work this morning on a 50 mile trip got about 15 miles into my journey the engine felt like it had started misfire and lose power
This continued for bout 10 miles misfiring and lack of power then it seemed to clear itself.
Until I stopped at a junction there was a definite change in the Engine note / sound a loud rattle could be heard during acceleration in every gear whilst acclerating however when reaching about 70mph the noise died down a little. It maybe me but it also appeared to use alot of fuel for the last 10 miles of my journey. Im thinking fuel starvation maybe filter but that would not produce the engine noise. I then thought it might be a faulty injector.
During this time the engine did not smoke / no engine light came on / Temperature stayed the same / No lights of any description / A definite rattle can be heard at tickover and when you rev or power on during acceleration and I suspect its drinking more fuel
Can anyone help me please?
Reply
#2
The First thing to do is replace you fuel filter i9f it was'nt replaced in the last few months....have you got diesel lately...?
If you get a leak back test done on all injectors this may pin point if its a dodgy injector.
Reply
#3
(04-11-2011, 06:00 AM)Newspaperman Wrote:  Help!!! Berlingo Multispace 1.9D
Driving to work this morning on a 50 mile trip got about 15 miles into my journey the engine felt like it had started misfire and lose power
This continued for bout 10 miles misfiring and lack of power then it seemed to clear itself.
Until I stopped at a junction there was a definite change in the Engine note / sound a loud rattle could be heard during acceleration in every gear whilst acclerating however when reaching about 70mph the noise died down a little. It maybe me but it also appeared to use alot of fuel for the last 10 miles of my journey. Im thinking fuel starvation maybe filter but that would not produce the engine noise. I then thought it might be a faulty injector.
During this time the engine did not smoke / no engine light came on / Temperature stayed the same / No lights of any description / A definite rattle can be heard at tickover and when you rev or power on during acceleration and I suspect its drinking more fuel
Can anyone help me please?

Please, check timing belt and phases of fuel injection.
Reply
#4
(06-11-2011, 12:41 PM)pk7478 Wrote:  
(04-11-2011, 06:00 AM)Newspaperman Wrote:  Help!!! Berlingo Multispace 1.9D
Driving to work this morning on a 50 mile trip got about 15 miles into my journey the engine felt like it had started misfire and lose power
This continued for bout 10 miles misfiring and lack of power then it seemed to clear itself.
Until I stopped at a junction there was a definite change in the Engine note / sound a loud rattle could be heard during acceleration in every gear whilst accelerating however when reaching about 70mph the noise died down a little. It maybe me but it also appeared to use a lot of fuel for the last 10 miles of my journey. I'm thinking fuel starvation maybe filter but that would not produce the engine noise. I then thought it might be a faulty injector.
During this time the engine did not smoke / no engine light came on / Temperature stayed the same / No lights of any description / A definite rattle can be heard at tickover and when you rev or power on during acceleration and I suspect its drinking more fuel
Can anyone help me please?

Please, check timing belt and phases of fuel injection.

Hi Newspaperman, there is a problem with the fuel pump on these vehicles, the pump wears a little bit and puts small pieces of brass into the fuel filter bowel, which can then be sent to the injectors. If you have not had the filter changed regularly its a problem. clean the filter housing out with some nice lint free rag etc, have a look for bits of brass.
you might need a injector to cure your problem, good luck.Cool
Reply




Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search








(Advanced Search)

[-]
Latest Threads
I'm getting alloys - but what?
Last Post: doofer
Today 10:36 PM
» Replies: 16
» Views: 668
Post your Ghetto Fabrication / Modifications "Ph...
Last Post: Kokain
Today 09:59 PM
» Replies: 34
» Views: 18691
Wishbone advice.
Last Post: jj9
Today 08:46 PM
» Replies: 4
» Views: 99
DESPERATE WITH MY BERLINGO DESIRE 2.0 HDI 2004 ...
Last Post: polar
Today 07:44 PM
» Replies: 22
» Views: 2512
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 07:37 PM
» Replies: 305
» Views: 30167
Lumpy Steering - What fluid is best?
Last Post: brodfather11
Today 07:27 PM
» Replies: 4
» Views: 149
brake discs
Last Post: jj9
Today 12:48 PM
» Replies: 1
» Views: 147
Insurance advice after crash
Last Post: Gravity
Today 12:42 PM
» Replies: 6
» Views: 880
Fuse for heater blower
Last Post: painter dave
Today 10:37 AM
» Replies: 1
» Views: 338
battery light
Last Post: painter dave
Today 10:21 AM
» Replies: 0
» Views: 119

[-]
Recent Visitors
Locations of visitors to this page