Thread Rating:
  • 7 Vote(s) - 2.57 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rumbling Noise
#1
Ladies and Gentleman i have had a rumbling noise from underneath the front, i at first checked the springs and they both seemed okay, i then pulled on most parts i could get to on the suspension, nothing seemed worn or loose, but i was teld and read that could possibly be the drop link rods, this afternoon i replaced the drivers side, now when i took the passenger side wheel off the rod looked new so i left it alone as it felt tight and looked okay. After going down the road to try it i thought that the rumble noise wasn't so bad, but slightly still there, now do i replace it or could it be something else.
Anyone had similar problems, or any ideas to pass on.
In advance thankyou.
Reply
#2
I have gone through several anti roll bar links.

They are supposed to best changed in pairs. I did my near side one and the off side went within a month.

You can't always tell if the bearing on them is shot until you remove it. For £10 a go I'd do them both.
[-] The following 1 user says Thank You to tucker for this post:
  • gary
Reply
#3
i have the same rumble on uneven ground,iv been under it a thousand times and cant find anything amiss,it drives me crazy not being able find it.please post if you find it
Reply
#4
could be the lower ball joints, they can be difficult to diagnose for movement though.
Somedays you're the pigeon, Somedays you're the statue.
[-] The following 1 user says Thank You to steve valentine for this post:
  • gary
Reply
#5
Just an update on the drop link rods, when i went to work on monday i still had the rumbling noise, i got home from work tonight and replaced the passenger side rod, an hour later all done tools put away now for a drive up the road i take to go to work where it was rumbling, yay lovely jubley not a rumble, so the lesson here is replace both sides together.
Solved i thinks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
where did they go ?
Last Post: Bootlebarth
Today 08:41 AM
» Replies: 7
» Views: 323
egs box
Last Post: billym
Yesterday 11:29 PM
» Replies: 14
» Views: 1327
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:57 PM
» Replies: 393
» Views: 57287
New to site
Last Post: Tomcat3
Yesterday 06:11 PM
» Replies: 2
» Views: 208
1.6 hdi lumpy cold start - SOLVED!
Last Post: Zion
Yesterday 11:43 AM
» Replies: 98
» Views: 15964
[SOLVED] Non-starting 1.6 HDI, now starts but EM...
Last Post: Mankee
Yesterday 10:41 AM
» Replies: 5
» Views: 629
ABS
Last Post: gazthelad
21-07-2018 05:45 PM
» Replies: 6
» Views: 1196
DIY Berlingo Day Van/Occasional Camper System [P...
Last Post: leftfootleashed
21-07-2018 11:20 AM
» Replies: 5
» Views: 826
Hands free radio
Last Post: Jakejjt
20-07-2018 10:03 PM
» Replies: 1
» Views: 530
Beacons and worklights
Last Post: Jakejjt
20-07-2018 09:42 PM
» Replies: 7
» Views: 1137

[-]
Recent Visitors
Locations of visitors to this page