Rumbling Noise
#1
Ladies and Gentleman i have had a rumbling noise from underneath the front, i at first checked the springs and they both seemed okay, i then pulled on most parts i could get to on the suspension, nothing seemed worn or loose, but i was teld and read that could possibly be the drop link rods, this afternoon i replaced the drivers side, now when i took the passenger side wheel off the rod looked new so i left it alone as it felt tight and looked okay. After going down the road to try it i thought that the rumble noise wasn't so bad, but slightly still there, now do i replace it or could it be something else.
Anyone had similar problems, or any ideas to pass on.
In advance thankyou.
Reply
#2
I have gone through several anti roll bar links.

They are supposed to best changed in pairs. I did my near side one and the off side went within a month.

You can't always tell if the bearing on them is shot until you remove it. For £10 a go I'd do them both.
[-] The following 1 user says Thank You to tucker for this post:
  • gary
Reply
#3
i have the same rumble on uneven ground,iv been under it a thousand times and cant find anything amiss,it drives me crazy not being able find it.please post if you find it
Reply
#4
could be the lower ball joints, they can be difficult to diagnose for movement though.
Somedays you're the pigeon, Somedays you're the statue.
[-] The following 1 user says Thank You to steve valentine for this post:
  • gary
Reply
#5
Just an update on the drop link rods, when i went to work on monday i still had the rumbling noise, i got home from work tonight and replaced the passenger side rod, an hour later all done tools put away now for a drive up the road i take to go to work where it was rumbling, yay lovely jubley not a rumble, so the lesson here is replace both sides together.
Solved i thinks.
Reply




Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search








(Advanced Search)

[-]
Latest Threads
Cold start and low revs issue
Last Post: KenZzx
Today 02:19 PM
» Replies: 3
» Views: 80
I'm getting alloys - but what?
Last Post: doofer
Today 01:55 PM
» Replies: 2
» Views: 44
Insurance advice after crash
Last Post: Gravity
Today 01:26 PM
» Replies: 4
» Views: 499
Berlingo Miltispace XTR (2008)
Last Post: squiddley
Today 10:28 AM
» Replies: 0
» Views: 42
post screen blacked out
Last Post: cancunia
Today 09:03 AM
» Replies: 46
» Views: 6003
DESPERATE WITH MY BERLINGO DESIRE 2.0 HDI 2004 ...
Last Post: cancunia
Today 07:01 AM
» Replies: 13
» Views: 1552
After filling up with fuel.
Last Post: doofer
Today 06:41 AM
» Replies: 5
» Views: 514
Battery occasionally totally drains overnight
Last Post: waggoner
Yesterday 11:42 PM
» Replies: 9
» Views: 794
Newbie Brake Pad Changing Advice Please
Last Post: geoff
Yesterday 09:37 PM
» Replies: 29
» Views: 3403
Heater resistor
Last Post: Kev_1664
Yesterday 08:41 PM
» Replies: 5
» Views: 392

[-]
Recent Visitors
Locations of visitors to this page