Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery occasionally totally drains overnight
#1
Berlingo XTR 2010
 
5 weeks ago total battery drain overnight, charge rate checked, new battery fitted, one week later same problem, battery so flat not even clock working,
car taken to auto electrician who said "can't find anything so have cleaned some relay terminals ". today three weeks later same thing again ,total electrical failure
Car doesn't do short runs ,is low mileage, in immaculate condition & is garage maintained, only thing I can think of is taking it to a different auto electrical  company.
Have any of you Berlingo folks come across anything similar Huh !!
Reply
#2
I've had the battery go flat overnight on another Citroen (not berlingo) and I think it was caused by the BSI not going into sleep mode, the car only ever did it the once.

So I would advise you to do a BSI reset and you never know it may just cure the problem, it's got to be worth a try.

Just search the forum or Google for Citroen BSI reset.


.
My vehicle .... 2006 (m59) Berlingo Multispace Desire - 1.6 HDI 92 
Reply
#3
Thanks, will check that out !
Reply
#4
Had that with my old berlingo,turns out was alternator draining battery ,parasitic draw when every thing was off,
Reply
#5
Thanks for that, I'll mention it to the autoelectrical guy's when I take the car in, though the problem only happens occasionally, It's particularly frustrating as my old Berlingo had four times the mileage on the clock & never missed a beat !
Reply
#6
could be dozens of reasons. most commonly is a relay failure, boot light that keeps burning, or an ecu that is failing (keeping can traffic active/not going to sleep)

If a lexia diagnosis does not com up with any results, then its trial and error with an "amp clamp" mesure device.

cheers,
Reply
#7
Thanks, that's good advice !
Reply
#8
The video is a bit long winded but it covers most points......

https://www.youtube.com/watch?v=KF1gijj03_0



.
My vehicle .... 2006 (m59) Berlingo Multispace Desire - 1.6 HDI 92 
Reply
#9
Here's a guess.

My Berlingo had a brand new battery early spring, and I realized immediately it was draining overnight (or after just a day or two). Totally flat, and it happened several times.  It mostly started fine and ran fine but only after a fresh charge. I simultaneously noted that the manually operated battery clamp (the useless bent metal thing) was not gripping tightly. However well I repeatedly cleaned the clamp, and scraped the battery terminal clean, I couldn't guarantee a good enough connection to get full cranking power (or sometimes it failed to turn over till I had wriggled it).

These two problems seem to be related.

I monitored the sleeping current of the vehicle after turning off the engine. I made a plot, and (with the battery contact good - ie freshly wiggled), I got the following:
900mA for a few seconds till the dashboard went out
800mA then tapering relatively smoothly in little jumps, steadily down to 110 mA after 5 minutes.
110mA with narrow "holes" (of a few seconds) down to 47mA . This phase lasted a further ~ 3 minutes.
Stepping down via a minute at 16 mA, to quiescent of ~ 9 mA over the next 2 minutes. 

So I get 9 mA final resting "off" current. Seems good, and no way that could be flattening the battery.

I still got a flat battery once more a few days later, associated also with the battery contact problem recurring.

So I chopped off the battery clamp and fitted a new solid bolt-on one.

Starting was solved (obviously), but really interestingly, the battery has held up perfectly, even through all that cold weather.

I have an idea that with a high resistance battery contact, the vehicle is unable to get the voltage readings it needs to sleep properly, and must have been be holding itself up, or re-booting somehow.  (Oddly though, even the ~1 Amp initial draw shouldn't have really flattened things overnight, but perhaps there was another higher current phase which I failed to measure). 

So pure speculation of course, but it worked for me.
Reply
#10
Thanks for your comments, I'll certainly check that one out !
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Brakes sticking
Last Post: keith1969
Today 03:44 AM
» Replies: 3
» Views: 244
New member
Last Post: keith1969
Today 03:37 AM
» Replies: 6
» Views: 245
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 10:13 PM
» Replies: 419
» Views: 64931
FOR SALE Amdro Bootjump £1100
Last Post: Quin
Yesterday 08:29 PM
» Replies: 1
» Views: 547
Berlingo 1.6 hdi bad knocking/tapping
Last Post: polar
Yesterday 06:41 PM
» Replies: 12
» Views: 1146
2007 Peugeot Partner Escapade 1.6Hdi
Last Post: shandy_bass
Yesterday 05:41 PM
» Replies: 3
» Views: 442
Solenoid not clicking
Last Post: Zweli
Yesterday 02:47 PM
» Replies: 0
» Views: 187
Recommend Socket Set
Last Post: V6BOY
Yesterday 02:04 PM
» Replies: 7
» Views: 1251
Corrosion on a B9?
Last Post: GraemeT
Yesterday 12:45 PM
» Replies: 10
» Views: 1205
Cheap Berlingo Multi space
Last Post: Lighty
Yesterday 10:46 AM
» Replies: 5
» Views: 467

[-]
Recent Visitors
Locations of visitors to this page