Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio not working
#1
Hi all, my radio does not work. It worked fine until I went on holiday for a week. I disconnected the battery as there have been a lot of van thefts in my area. Came back from holiday, reconnected battery, radio fine for about 5 minutes then it went off and it started the beep intermittently.
Its a 2005 Berlingo Enterprise.
Radio model is PU-2471A(J)
Thanks in advance
Reply
#2
Odd, sounds like a failure. My stock radio in my 2006 enterprise failed a couple of years ago, it turned on but no sound coming through any of the speakers. I replaced it with a JVC unit with Bluetooth for £65 in the end and I managed to find a steering control unit that was compatible with it on ebay for £20. Not had a problem since
2006 Citroen Berlingo Enterprise 600D
420k+ on the clocks and still chugging away   Big Grin
Reply
#3
If the radio is beeping it sounds like it hasn't recognised the radio security code. You could try removing the battery again but do a BSI shutdown first and then follow procedure when connecting the battery again.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#4
(08-05-2018, 07:47 PM)Tomcat3 Wrote:  If the radio is beeping it sounds like it hasn't recognised the radio security code. You could try removing the battery again but do a BSI shutdown first and then follow procedure when connecting the battery again.

What's s BSI shut down??
Reply
#5
Have a read of the second chapter on this site http://www.petercoopercarrepairs.co.uk/p...cedure.htm
Take notice of the shut down wait a few minutes for the bsi unit to go to sleep.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Weird speedo and power issues
Last Post: geoff
Yesterday 06:59 PM
» Replies: 8
» Views: 240
Terrible squeaking noise during accelartion DV6F...
Last Post: geoff
Yesterday 06:46 PM
» Replies: 21
» Views: 440
E-Remote app not on e-Berlingo 2022 ?
Last Post: Leonberger
Yesterday 05:14 PM
» Replies: 7
» Views: 243
Wiring to Driver's Seat Belt Buckle
Last Post: Gollycrush
Yesterday 04:31 PM
» Replies: 3
» Views: 332
Did this fall off my car?
Last Post: evdama
Yesterday 01:37 PM
» Replies: 10
» Views: 786
My Camper
Last Post: Divechick
Yesterday 08:51 AM
» Replies: 6
» Views: 199
Shelving
Last Post: evdama
Yesterday 06:47 AM
» Replies: 2
» Views: 79
Cargo Bay Side Panel Removal (B9 Van)
Last Post: evdama
Yesterday 06:34 AM
» Replies: 1
» Views: 65
2003 manual 1.4 petrol berlingo won't idle and h...
Last Post: Jtgsx
Yesterday 05:09 AM
» Replies: 0
» Views: 49
Eat8 servicing ?
Last Post: chrisl
22-06-2024 04:49 PM
» Replies: 7
» Views: 176

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK