Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio Display not working
#1
Evening All

I have a 63 reg XTR with the "type c display"  thats comleatly dark ... its not the bulbs having taken the disply to bits its all LED's 

Radio/CD Works not sure about blue tooh and if the revesing sensors too to late check

Does any one have any info on the wiring to the display, I've worked out the ground and the sidlights - but theres no power to the dispaly on any oth the others I assume there shoule be 12Votls soem where on the red wire ?

I see that the display is avaible on Ebay but I don't think thats the issue

Cheers for now
Jake
Reply
#2
Could it be that the display dimmer has been turned down if you have one that is??
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Hi Tomcat tnx for the reply but no ....
Checking with Lexia helpfuly shows no Comms to display Bluetooth works for calls and music no parking sensors thought .... More invistigation needed
Jake
Reply
#4
Hi All
Well after a lot of messing about I took the dispaly out and set about it on the work bench and found the processor crystal was duff - (tranaslated there's a computer to run the dispay and the timing had stopped) replaced the 42pence part and all is well Smile

Not recomended unless your handy with a soldering iron and test equipment Wink

Jake
Reply
#5
(15-05-2018, 10:56 PM)Jakejjt Wrote:  Hi All
Well after a lot of messing about I took the dispaly out and set about it on the work bench and found the processor crystal was duff - (tranaslated there's a computer to run the dispay and the timing had stopped) replaced the 42pence part and all is well Smile

Not recomended unless your handy with a soldering iron and test equipment Wink

Jake

I'm impressed. Care to share how you diagnosed that fault?
Reply
#6
(16-05-2018, 06:58 AM)cancunia Wrote:  
(15-05-2018, 10:56 PM)Jakejjt Wrote:  Hi All
Well after a lot of messing about I took the dispaly out and set about it on the work bench and found the processor crystal was duff - (tranaslated there's a computer to run the dispay and the timing had stopped) replaced the 42pence part and all is well Smile

Not recomended unless your handy with a soldering iron and test equipment Wink

Jake

I'm impressed. Care to share how you diagnosed that fault?
I can but how much sense it makes will depend on your electronics skills ( its what I do for work for too many years )  and how much you know about processors?
 If you don't  this won't make much sense..

So remove from car connect power to pins 1 +12 and 3 Ground I TNINK Check befor you DO!!!
Have a look with a scope to see if the 2 crystals are working - the 32Khz one is for the clock and the 16Mhz is the dipslay processor clock.
On mine the 32K was Ok but nothing on the 16M one - change the crystal for another one to check the procersor was Ok it was :Smile get and fit new 16M one.
Sounds simple but the prorocessor only fires up for about 1 second as you apply power then if it cant talk to the car turns off ( a common way of doing things)  so you have to be quick that bit had me for a while

Cheers Jake
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Number plate lights staying on.
Last Post: Gordon Taylor
Yesterday 08:45 PM
» Replies: 4
» Views: 280
handbrake travel and wheels fitment
Last Post: rapidyellow
Yesterday 07:13 PM
» Replies: 2
» Views: 447
2016 berlingo 1.6 hdi oil change time
Last Post: jj9
Yesterday 06:26 PM
» Replies: 27
» Views: 2418
P0115 fault
Last Post: Dizzydave
Yesterday 03:42 PM
» Replies: 0
» Views: 168
berlingo clutch pedal play
Last Post: cancunia
Yesterday 01:01 PM
» Replies: 19
» Views: 15386
Old member returning
Last Post: Yorkshire Bling
Yesterday 10:53 AM
» Replies: 3
» Views: 497
Just bought a 1.6HDi - a few questions
Last Post: cancunia
Yesterday 07:03 AM
» Replies: 3
» Views: 383
Dip beam level adjustment motor
Last Post: Blackshuck
Yesterday 05:55 AM
» Replies: 3
» Views: 569
where did they go ?
Last Post: ajcommercial
20-08-2018 11:06 PM
» Replies: 8
» Views: 829
Random beep
Last Post: ajcommercial
20-08-2018 10:39 PM
» Replies: 4
» Views: 631

[-]
Recent Visitors
Locations of visitors to this page