Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spring Rubbing issue
#1
Hello all,

I have owned a 04 plate berlingo 2.0 HDi for 3 years. One year into ownership and the front drivers side suspension spring snapped. I got a new one from eurocarparts and fitted it. Ever since fitting it when steering there was a rubbing noise. I found the very top of the spring was rubbing against the cars inner wheel arch.

Things i have considered:

I have does something incorrect when putting it all back together.

I have put the spring in the wrong way around. Looks like it could go in either way though.

The spring is wrong, even though it fits the cups nice.


Any suggestions are welcome. I currently have the stut off and the spring out. Looking through the top mount hole you can see where it has been rubbing.

Note sure what to do now?

Cheers
Bob

euro car part no. 627545140 was fitted.
Found this on another post
"i had a broken spring replaced and the garage had not seated the top bearing correctly which caused a twang on bumps and turns."

Looked at how the top bearing seats and i can not see that as being the problem.
Reply
#2
Can you get a picture of the rubbing ?
Reply
#3
yeah that is a good idea. To dark now to take a good photo but I will upload first thing tomorrow. I'm not the best at describing things so a picture be better.

Looks like the spring has been rubbing agaist the chassis. Right at the top. I have looked at the other side and it is close, but not touching. Not sure how this has occurred. It was the first time i swapped a spring so could well be something i have done.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
2.0 Hdi starting (another one)
Last Post: Tomcat3
Today 08:24 PM
» Replies: 14
» Views: 775
ply and head lining
Last Post: Tomcat3
Today 08:16 PM
» Replies: 1
» Views: 61
citroen virgin
Last Post: Tomcat3
Today 08:11 PM
» Replies: 5
» Views: 116
Headlights staying on
Last Post: rublehousen
Today 04:07 PM
» Replies: 6
» Views: 426
Revving problem ?
Last Post: MCGRAW80
Today 03:34 PM
» Replies: 3
» Views: 117
Heater resistor
Last Post: lennythelion
Today 03:20 PM
» Replies: 10
» Views: 1463
B9 tuning update
Last Post: northroadycles
Today 12:50 PM
» Replies: 2
» Views: 577
Lesure battery charging
Last Post: Arfcollins
Today 12:09 PM
» Replies: 11
» Views: 1429
exhaust sheared at bottom of cat
Last Post: BLINGO BOMBA
Today 11:02 AM
» Replies: 2
» Views: 287
Leisure battery wiring advice.
Last Post: MrDrizz
Today 10:15 AM
» Replies: 0
» Views: 130

[-]
Recent Visitors
Locations of visitors to this page