Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spring Rubbing issue
#1
Hello all,

I have owned a 04 plate berlingo 2.0 HDi for 3 years. One year into ownership and the front drivers side suspension spring snapped. I got a new one from eurocarparts and fitted it. Ever since fitting it when steering there was a rubbing noise. I found the very top of the spring was rubbing against the cars inner wheel arch.

Things i have considered:

I have does something incorrect when putting it all back together.

I have put the spring in the wrong way around. Looks like it could go in either way though.

The spring is wrong, even though it fits the cups nice.


Any suggestions are welcome. I currently have the stut off and the spring out. Looking through the top mount hole you can see where it has been rubbing.

Note sure what to do now?

Cheers
Bob

euro car part no. 627545140 was fitted.
Found this on another post
"i had a broken spring replaced and the garage had not seated the top bearing correctly which caused a twang on bumps and turns."

Looked at how the top bearing seats and i can not see that as being the problem.
Reply
#2
Can you get a picture of the rubbing ?
Reply
#3
yeah that is a good idea. To dark now to take a good photo but I will upload first thing tomorrow. I'm not the best at describing things so a picture be better.

Looks like the spring has been rubbing agaist the chassis. Right at the top. I have looked at the other side and it is close, but not touching. Not sure how this has occurred. It was the first time i swapped a spring so could well be something i have done.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
handbrake travel and wheels fitment
Last Post: cancunia
Today 03:18 PM
» Replies: 7
» Views: 892
Alternator not charging no 12v at small purple w...
Last Post: Art b
Today 01:30 PM
» Replies: 4
» Views: 13405
2004 alternator not charging
Last Post: frank
Today 01:28 PM
» Replies: 1
» Views: 84
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gravity
Today 01:09 PM
» Replies: 10
» Views: 4057
Central locking problem
Last Post: srcomp
Today 12:43 PM
» Replies: 0
» Views: 47
How to fit grease nipple on rear axle berlingo
Last Post: cancunia
Today 11:11 AM
» Replies: 10
» Views: 7140
rear axle mot failure
Last Post: jj9
Today 09:51 AM
» Replies: 3
» Views: 401
2018 Berlingo Brochure with prices for your view...
Last Post: Tree
Today 09:27 AM
» Replies: 3
» Views: 333
Window regulator
Last Post: jj9
Today 08:23 AM
» Replies: 6
» Views: 587
Car wanted...now acquired
Last Post: Art b
Today 06:51 AM
» Replies: 8
» Views: 1090

[-]
Recent Visitors
Locations of visitors to this page