Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] P1351 fault code
#1
i got a problem of a fault code P1351 code and the engine would not start, the engine is cranking , and the starter &  battery are good , it has suddenly got this issue , despite i had done a + 70km journey for my work ( while is routine) , the oil seal injector 1,2 are leaking oil a bit much which make the engine an oily back side where the starter is, please help me for this issue, i badly need it :/ i got a rip off off a bad mechanic who has stolen my 2nd engine block and new spare parts :Sad i want to solve it with little money as possible ,
Reply
#2
Your fault code is probably related to the glow plugs, either the relay that controls the plugs, or maybe the plugs themselves.

https://www.berlingoforum.com/thread-4725.html
Reply
#3
I get that code everytime I plug my scanner in but there's nothing wrong with my car. I clear it but still comes back.
Maybe consider it's another problem?
Reply
#4
UPDATE: while checking the electrical wires and sensor. the sensor on the common rail registered a 0.5v instead of 1.5v to open the injectors, the mechanics and electrician are saying one of the following might be replace : fuel pump or the common rail sensor .( will update soon )
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Snow Tyres
Last Post: Gollycrush
Yesterday 09:32 PM
» Replies: 0
» Views: 60
EML light on - No Fault Code
Last Post: TONX
Yesterday 08:05 PM
» Replies: 0
» Views: 85
No Click from Solenoid
Last Post: Zweli
Yesterday 07:46 PM
» Replies: 0
» Views: 84
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Yesterday 07:11 PM
» Replies: 24
» Views: 8724
What website to pass time over a winters evening...
Last Post: josegar
Yesterday 05:05 PM
» Replies: 5
» Views: 2619
Headlight adjustment
Last Post: Sophiante
Yesterday 05:02 PM
» Replies: 2
» Views: 522
Hi from a me and what to do.
Last Post: cancunia
Yesterday 04:49 PM
» Replies: 3
» Views: 220
2004 alternator not charging
Last Post: Art b
Yesterday 10:58 AM
» Replies: 3
» Views: 587
AUX install for radio
Last Post: ntm1275
22-09-2018 10:17 PM
» Replies: 3
» Views: 771
Lowering springs
Last Post: DMaclean
22-09-2018 07:28 PM
» Replies: 0
» Views: 313

[-]
Recent Visitors
Locations of visitors to this page