Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
new here
#1
hi there new to this forum I have a 2004 forte in silver had a few probs when I bought it so far I have flushed cooling system and changed oil sorted radiator fan prob and had a quick look at the brakes still to do change brake shoes and pads and fix odometer as its not working found fault code p1351 but will look closer at that when the rest is complete all help gratefully received and will do my best to help others
Reply
#2
Hello marksue and welcome to the forum.
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
Hello, dear friend very welcome to this forum I am also new here and I am about to buy a car.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Snow Tyres
Last Post: Gollycrush
Yesterday 09:32 PM
» Replies: 0
» Views: 60
EML light on - No Fault Code
Last Post: TONX
Yesterday 08:05 PM
» Replies: 0
» Views: 85
No Click from Solenoid
Last Post: Zweli
Yesterday 07:46 PM
» Replies: 0
» Views: 84
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Yesterday 07:11 PM
» Replies: 24
» Views: 8725
What website to pass time over a winters evening...
Last Post: josegar
Yesterday 05:05 PM
» Replies: 5
» Views: 2619
Headlight adjustment
Last Post: Sophiante
Yesterday 05:02 PM
» Replies: 2
» Views: 522
Hi from a me and what to do.
Last Post: cancunia
Yesterday 04:49 PM
» Replies: 3
» Views: 220
2004 alternator not charging
Last Post: Art b
Yesterday 10:58 AM
» Replies: 3
» Views: 587
AUX install for radio
Last Post: ntm1275
22-09-2018 10:17 PM
» Replies: 3
» Views: 771
Lowering springs
Last Post: DMaclean
22-09-2018 07:28 PM
» Replies: 0
» Views: 313

[-]
Recent Visitors
Locations of visitors to this page