Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ABS
#1
Afternoon, does any member know what ABS code 5331 undefined relates to please....
Thanks in advance?
Reply
#2
may be abs speed sensor fault......
Reply
#3
A quick internet search shows this to be a Right Front Wheel sensor - this was on a Peugeot 207 so probably applies to a Berlingo. Have a search around - you should find more info.
Regards.
Reply
#4
(19-07-2018, 09:43 PM)Boxer Wrote:  A quick internet search shows this to be a Right Front Wheel sensor - this was on a Peugeot 207 so probably applies to a Berlingo. Have a search around - you should find more info.
Regards.

Morning, yes I initially went for the right hand front speed sensor, but after changing ABS light still came on after driving so swapped it over with left hand front and still same. Tried google search but can’t pin point this error code. Suppose it’s going to have to go to main dealer  Angry
Reply
#5
may be the magnetic part on wheel hub needs cleaning........if its gumbed up,won't be making magnet field to sensor
Reply
#6
(20-07-2018, 10:10 AM)gazthelad Wrote:  may be the magnetic part on wheel hub needs cleaning........if its gumbed up,won't be making magnet field to sensor

Yep thought that as well tried brake cleaning on the mag abductor rings to no avail, really hoping it’s not the ecu on the pump but think it may be .....
Reply
#7
clear all error codes in lexia........then see if fault comes back......
Reply
#8
If you have replaced the sensor, and the air gap is good between the sensor & pick up , you may have a wiring fault.
We have had several C4 Picasso’s with this issue on the 0/s/f. 
It will take some fixing, dealers will not come up with a solution you will like.
Maybe a new harness Angry
The best fix is to get access to the abs computer (n/s/f wheelarch) find out which wires go to the offending sensor & check for continuity.
If one wire has failed, they are twisted pairs, and often corrode together. The best remedy (cost Effective) is to run two new wires to the sensor.
Give me a call if you need help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
B9 tuning update
Last Post: northroadycles
Today 12:50 PM
» Replies: 2
» Views: 485
Lesure battery charging
Last Post: Arfcollins
Today 12:09 PM
» Replies: 11
» Views: 1266
exhaust sheared at bottom of cat
Last Post: BLINGO BOMBA
Today 11:02 AM
» Replies: 2
» Views: 201
2.0 Hdi starting (another one)
Last Post: Norfolkboy
Today 11:01 AM
» Replies: 13
» Views: 622
Leisure battery wiring advice.
Last Post: MrDrizz
Today 10:15 AM
» Replies: 0
» Views: 51
Custom PIDs for Torque App, 1.6HDi
Last Post: saskak
Today 08:06 AM
» Replies: 2
» Views: 229
Valves DW8
Last Post: Art b
Yesterday 11:29 PM
» Replies: 48
» Views: 8356
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:47 PM
» Replies: 564
» Views: 106788
Brake Pipe & Unions
Last Post: ffrenchie
Yesterday 07:34 PM
» Replies: 5
» Views: 860
Cheap wheels, trims and tyres
Last Post: northroadycles
Yesterday 05:43 PM
» Replies: 0
» Views: 200

[-]
Recent Visitors
Locations of visitors to this page