Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] [Solved] Yet another suspension noise thread [drop links]
#1
Hi all

As it says in the title - noise from the front end.

Symptoms - difficult to reproduce but can be found sometimes if (a) accelerate hard up a moderate hill in 2nd gear then take foot off throttle abruptly (b) on a wide/shallow speed hump approached square on sometimes as the front end drops on the down side of it

Noise - a single, gentle click/clunk - as if you gently rapped a knuckle once on a bare floorboard. No feedback via steering.

Side - left hand  feels as if towards lower end of the suspension system but we all know these things can be elusive.

So far - checked all the left hand side bolts/joints/track rods/drop links etc etc - most were replaced this year - everything is tight and looks good. No play in the wheel. Caliper and carrier rock solid. Steering rack firmly bolted in, all tie rods are 100%. Springs correctly fitted to cups/mountings. Sub frame bolts all OK. Battery not loose. ECU not loose. Driveshaft feels OK - no free play in knuckle or at gearbox end. Wheel nuts all tight. Anti Roll bar bushes all good.

The only thing I have left to double check is the top suspension mounting - that was replaced in January but when I get a minute I'll pull the ECU and recheck it. No sign of free play though when car jacked up and using pry bar to move suspension units around.

This is intermittent, fairly quiet but is bugging the heck out of me. 

Can anybody shed some light? I've been through the forums but cannot find any thread that mentions anything other than the things I have tried already.

Thanks

Graeme
                                                                                                                                                                                             
Our car - 2008 1.6 HDi 92 Multispace. 150,000 miles + counting. 15,000 + miles in our care. 48.88 mpg ave in that time
Reply
#2
Only thing that comes to mind is the strut pistons or maybe the stops at the top of the struts.
Reply
#3
Gearbox mount?

.
My vehicle .... 2006 (m59) Berlingo Multispace Desire - 1.6 HDI 92 
Reply
#4
When where the drop links last changed have come across numerous with absolutely minimal to no play to cause no end of noise from the suspension.
Reply
#5
Hi everybody - thanks for the suggestions - gearbox mounting is OK, struts and top bearings OK - drop links?

Replaced those in January with Delphi branded ones - however I'd also come across these as prime suspects after some serious Googling so I have ordered a different branded pair and and we'll see what results we get
                                                                                                                                                                                             
Our car - 2008 1.6 HDi 92 Multispace. 150,000 miles + counting. 15,000 + miles in our care. 48.88 mpg ave in that time
Reply
#6
Hello all - 

I tightened up the nuts on the original drop links as far as possible and that (initially) reduced the noise but, over a few days, back it came.

Binned those drop links and fitted new ones from GSF and bingo - all good. 
Happy bunny.
                                                                                                                                                                                             
Our car - 2008 1.6 HDi 92 Multispace. 150,000 miles + counting. 15,000 + miles in our care. 48.88 mpg ave in that time
Reply
#7
Good news, glad you found it!
I had a similar problem last year with the drop links, took me weeks to find the really small amount of play on one of them.
Reply
#8
Great result you got to the bottom of it good stuff.
Reply
#9
Thanks guys - even though it was a small click/clunk my wife drives the car a lot and I didn't like the idea of something 'not right'. Bit disappointed at having to bin the drop links from January but the new ones were not that expensive - buy cheap, buy twice my wife often reminds me :-)
                                                                                                                                                                                             
Our car - 2008 1.6 HDi 92 Multispace. 150,000 miles + counting. 15,000 + miles in our care. 48.88 mpg ave in that time
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
How to test Stop Solenoid
Last Post: Zweli
Today 02:49 AM
» Replies: 2
» Views: 169
Gear linkage
Last Post: jj9
Yesterday 10:42 PM
» Replies: 1
» Views: 127
ABS Light
Last Post: bazstivy
Yesterday 08:26 PM
» Replies: 13
» Views: 1253
Centre Multifunction Display
Last Post: hawaiianblue
Yesterday 05:59 PM
» Replies: 2
» Views: 245
Trukrax, berlingo roof rack
Last Post: Art b
Yesterday 05:33 PM
» Replies: 0
» Views: 127
Rear seats from 2012 Citroen Berlingo Multispace
Last Post: Kokain
Yesterday 03:09 PM
» Replies: 2
» Views: 459
Do all of these come with rcl?
Last Post: hawaiianblue
Yesterday 12:38 PM
» Replies: 3
» Views: 613
My Berlingo Camper build.....
Last Post: 48pop
Yesterday 11:13 AM
» Replies: 23
» Views: 8612
The Condensation issue
Last Post: Gravity
Yesterday 07:44 AM
» Replies: 13
» Views: 2654
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
15-10-2018 10:09 PM
» Replies: 461
» Views: 76715

[-]
Recent Visitors
Locations of visitors to this page