Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speedo and odo do not work
#1
Could somebody tell me what is the oem part number for the transducer on gearbox of the 2.0 hdi berlingo. The year is 2003.
Reply
#2
Try and look it up using your VIN number at the site below....

https://www.catcar.info/citroen/?lang=en&l=


.
My vehicle .... 2006 (m59) Berlingo Multispace Desire - 1.6 HDI 92 
[-] The following 1 user says Thank You to jj9 for this post:
  • Doc_Brown
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Looking for a B9 with Modutop
Last Post: cancunia
Today 07:12 AM
» Replies: 2
» Views: 194
2010 1.6L HDI berlingo SOMETIMES wont start
Last Post: diien
Today 03:03 AM
» Replies: 8
» Views: 556
COFUSED .COM
Last Post: polar
Yesterday 08:19 PM
» Replies: 4
» Views: 295
Hand Priming Pump
Last Post: Lighty
Yesterday 08:09 PM
» Replies: 5
» Views: 437
Speedo binnacle fault
Last Post: cancunia
Yesterday 07:01 PM
» Replies: 1
» Views: 134
mountings
Last Post: bikey
Yesterday 01:31 PM
» Replies: 2
» Views: 281
Adding seats to the back
Last Post: TheCraftyCarpenter
Yesterday 12:12 PM
» Replies: 2
» Views: 535
1.6 Blue HDi 100 Engine appear to be burning oil
Last Post: geoff
Yesterday 12:02 PM
» Replies: 17
» Views: 1996
Front brake caliper retaining bolts
Last Post: geoff
19-10-2019 09:52 PM
» Replies: 5
» Views: 480
Bad throw out bearing at idle?
Last Post: geoff
19-10-2019 08:01 PM
» Replies: 6
» Views: 731

[-]
Recent Visitors
Locations of visitors to this page