Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
indicator stalk problem?
#1
When I click my right hand indicator, it clicks a few times, then stops, then the headlights come on by themselves! Also the 'lights on' warning beeper sounds when the driver door is opened even if the lights are off. If I keep the sidelights on then the indicator works as normal. Would this be an indicator stalk issue? anyone else suffered this problem....and know how to fix it? thoughts gratefully received!!!
Reply
#2
sounds like a comms unit problem - just replace the comms unit
Reply
#3
I agree with POLAR I have the same problem on a 2002 1.6 16v berlingo.
Reply
#4
(02-10-2018, 10:35 PM)Squad Wrote:  I agree with POLAR I have the same problem on a 2002 1.6 16v berlingo.

Did this get repaired? I now have this issue, exactly same symptoms.  There are several fixes on youtube which all appear different.
How much would a garage charge for this?
Expect the comms 2000 unit wont come cheap....
Fb
Reply
#5
(21-01-2021, 09:35 PM)BLINGO BOMBA Wrote:  
(02-10-2018, 10:35 PM)Squad Wrote:  I agree with POLAR I have the same problem on a 2002 1.6 16v berlingo.

Did this get repaired? I now have this issue, exactly same symptoms.  There are several fixes on youtube which all appear different.
How much would a garage charge for this?
Expect the comms 2000 unit wont come cheap....
Fb

I lived with it for a while and drove everywhere with the sidelights on which stopped the beeping noise - it developed into beeping when the drivers door opened - then the central locking packed up. Whether this is all related I have no idea. Weirdly the initial problem seems to have now rectified itself and Im just left with no central locking, which I'm not really bothered about!
Reply
#6
I had the same problem but ever since I changed my lights to led bulbs I've had not problem since.
Reply
#7
Need to sort it for MOT' otherwise would just drive with lights on as Mr Greencar.
Is Led upgrade a simple bulb change?  
Did you change headlights & indicators to LED?
Fb
Reply
#8
(22-01-2021, 10:52 PM)BLINGO BOMBA Wrote:  Need to sort it for MOT' otherwise would just drive with lights on as Mr Greencar.
Is Led upgrade a simple bulb change?  
Did you change headlights & indicators to LED?
Fb

I have changed all of my lights to LED bulbs.
Reply
#9
Ive now stripped the steering wheel & shrouding off & can see the comms 2000 is a Delphi unit & not a Dav.  Apparently the Dav units are repairable with a new plunger on the end of the indicator stalk, but this is not the case for the Delphi unit.
I understand replacement units need the same part no. but having trawled ebay there are loads of different numbers for these units.  I have found units with the first 5 digits but the last 3 digits are different.  
Is this critical to have the whole no. identical?
My part is PSA 96595 107 XT.
Reply
#10
I had a similar problem with a COM2005 Delphi unit (https://www.berlingoforum.com/thread-20412.html). Temporary solution which might work is to stick two toothpicks in the indicator stalk, see photos in the thread. Worked without a problem. If you do not want to spend money to fix it, you can open the indicator stalk (also in the thread). One of the contacts is pushed down and gives wrong command to the ECU. Bend it to the way the other two are and it should be good.
I bought a second hand unit with the same numbers and no problem with the stalk anymore. If you want a more visual thing here is a video and how to check the COM2005 numbers: https://www.youtube.com/watch?v=2UIQlxj0lZE

Let me know for any questions. It is definitely not the plunger as the DAV unit, as I also replaced the two plungers, but that did not help at all, the plunger is markedly different than the DAV unit.
smile, you are alive!
[-] The following 1 user says Thank You to saskak for this post:
  • BLINGO BOMBA
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Rattle / rubber rubbing sound from the dash area
Last Post: Desdinova
Today 03:43 PM
» Replies: 3
» Views: 450
Moving without touching the accelerator
Last Post: deejay_xb
Today 03:14 PM
» Replies: 10
» Views: 598
Rear shocks
Last Post: larry46
Today 02:31 PM
» Replies: 18
» Views: 1941
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 10:19 AM
» Replies: 1436
» Views: 407689
Photo upload
Last Post: my mucker
Today 09:50 AM
» Replies: 13
» Views: 803
Buying an automatic van
Last Post: Bert35
Today 09:33 AM
» Replies: 3
» Views: 370
help needed
Last Post: cancunia
Today 08:42 AM
» Replies: 26
» Views: 2381
Floor liner.
Last Post: Zion
Today 06:22 AM
» Replies: 9
» Views: 1052
Howdy
Last Post: Rasputin
Yesterday 11:23 PM
» Replies: 1
» Views: 211
Worst bits of foam rubber in the world!
Last Post: Al Jones
Yesterday 10:23 PM
» Replies: 82
» Views: 11175

[-]
Recent Visitors
Locations of visitors to this page