Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Showing as overheating
#1
Hi can anyone help?
2006 1.9D Berlingo.
New water pump, new radiator, new 2 stage thermostat, flushed several times, still showing as overheating, compression tested, chemical test to see if combustion in water negative.
Still showing as over heating.
Could it be faulty gauge or temp sensor or BSI fault????
Where do I go from here??? Arrrrgh!!!
Reply
#2
With a 1.9D I thought the issue was 'not enough heat'...
(The Suzuki Baleno I drove for a while had the TD version of that engine. Bl**dy cold experience)

If you run it up to temp the radiator hoses should 'firm up' and also heat up. Can you feel any heat from them?
(don't touch the top hose directly... )

How long until the temperature is too high?
[-] The following 1 user says Thank You to Gadgetman for this post:
  • Art b
Reply
#3
(08-10-2018, 12:38 PM)Tansloyd Wrote:  Hi can anyone help?
2006 1.9D Berlingo.
New water pump, new radiator, new 2 stage thermostat, flushed several times, still showing as overheating, compression tested, chemical test to see if combustion in water negative.
Still showing as over heating.
Could it be faulty gauge or temp sensor or BSI fault????
Where do I go from here??? Arrrrgh!!!

Can you get a temp sensor on the top hose or top of the radiator? Something like a stove pipe thermometer, cooking thermometer, infra red thermometer etc. It may help to diagnose if it's a sensor or something else.
Also, not sure about the 1.9, but the HDi engines have OBD data to show coolant temp.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Eberspacher or similar
Last Post: hawaiianblue
Today 01:20 AM
» Replies: 8
» Views: 1394
injectors wjy 1.9d
Last Post: jj9
Yesterday 11:13 PM
» Replies: 4
» Views: 215
New windscreen
Last Post: Hardnut
Yesterday 08:49 PM
» Replies: 3
» Views: 133
ABS Light
Last Post: bazstivy
Yesterday 08:38 PM
» Replies: 19
» Views: 1790
EML light on - No Fault Code
Last Post: TONX
Yesterday 06:31 PM
» Replies: 8
» Views: 1555
New in a Berlingo that need a new injection pump...
Last Post: swedish
Yesterday 06:14 PM
» Replies: 3
» Views: 296
2008 1.6 hdi lack of power ?
Last Post: GraemeT
Yesterday 06:05 PM
» Replies: 19
» Views: 1334
Adding Keys with Lexia
Last Post: cancunia
Yesterday 03:45 PM
» Replies: 9
» Views: 616
Starter motor replacement
Last Post: frank
Yesterday 03:39 PM
» Replies: 7
» Views: 630
Centre Multifunction Display
Last Post: hawaiianblue
Yesterday 02:21 PM
» Replies: 3
» Views: 448

[-]
Recent Visitors
Locations of visitors to this page