2.0 HDI - pre-heaters not working?
#1
Question 
As the weather has got colder the Berlingo has got harder to start. The pre-heater lamp doesn't illuminate at all, which could of course just be a blown bulb. Anyone able to suggest a quick way of checking if the heaters themselves are functioning?

I suspect a new battery may be on the cards too as after the first few seconds it's not turning over very quickly (fortunately so far it's fired up before it's given up, so to speak) but I'd like to know if the pre-heaters are working before the weather really turns cold.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2004 Berlingo Multispace Forte 2.0HDi in red.
Reply
#2
Hi Snaprails.
At first, check fuses in BSI, BSM and PSF(if you car has it).
Reply
#3
(28-11-2011, 09:16 AM)pk7478 Wrote:  Hi Snaprails.
At first, check fuses in BSI, BSM and PSF(if you car has it).

PSF?

According to the book of words the preheat shares a fuse with the reversing lights, I checked and they work. Is there another fuse I should look for?

Googling and searching this forum does suggest that the lamp rarely comes on unless it's below freezing so maybe my thoughts re battery may be close to the mark, will have to get torch out later and see if there's a date on it.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2004 Berlingo Multispace Forte 2.0HDi in red.
Reply
#4
(28-11-2011, 09:49 AM)snaprails Wrote:  
(28-11-2011, 09:16 AM)pk7478 Wrote:  Hi Snaprails.
At first, check fuses in BSI, BSM and PSF(if you car has it).

PSF?

According to the book of words the preheat shares a fuse with the reversing lights, I checked and they work. Is there another fuse I should look for?

Googling and searching this forum does suggest that the lamp rarely comes on unless it's below freezing so maybe my thoughts re battery may be close to the mark, will have to get torch out later and see if there's a date on it.

PSF - small fuse box under BSM.

VIN of you car to my PM, please.
Reply
#5
Quite well documented/discussed in other threads.Please do a search for other replies within the forum....
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#6
Hi, "PFS" is the engine bay fuse box, Check fuse 1 (10A).

Also check the connection on your water temp sensor which is below the vaccuum unit on the end of the camshft.

Mine's a green plug/socket with 2 wires - one yellow, one white.

Cheers :thumbsup:

2006 2.0hdi 600 with bench seat.  Cool
[-] The following 1 user says Thank You to Rustscrat for this post:
  • pk7478
Reply
#7
(28-11-2011, 11:20 AM)Rustscrat Wrote:  Hi, "PFS" is the engine bay fuse box, Check fuse 1 (10A).
BSM calls PSF in diagrams.
PCF it's other unit.
Reply
#8
Update:
All fuses checked ok. Weather finally got cold enough for glow plugs and lamp lit. At which point the battery, which tested fine decided enough was enough. New battery and things are much better, not exactly bursting into life as soon as the key turns but much more able to turn the engine fast enough for it to fire within 10 secs.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2004 Berlingo Multispace Forte 2.0HDi in red.
Reply
#9
I've marked this as solved as it sort of solved itself - can still be posted on though..
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#10
My battery has been showing signs of giving up for a while now but after initial slow turn over from cold it is ok all day.

Yesterday was the first time this new season that the pre-heater light came on on the dash. It seemed to stay on for quite a while considering it was only just around freezing. Last winter in temperatures of up to minus 15-20 deg C, the light just flashed for a split second and she fired up straight away. Did not go on first turn yesterday so went back through a full start procedure to see if the light came on again. Stayed on a while then after turning the key, fired up straight away no white smoke or anything....
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply




Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search








(Advanced Search)

[-]
Latest Threads
I'm getting alloys - but what?
Last Post: doofer
Today 10:36 PM
» Replies: 16
» Views: 673
Post your Ghetto Fabrication / Modifications "Ph...
Last Post: Kokain
Today 09:59 PM
» Replies: 34
» Views: 18699
Wishbone advice.
Last Post: jj9
Today 08:46 PM
» Replies: 4
» Views: 102
DESPERATE WITH MY BERLINGO DESIRE 2.0 HDI 2004 ...
Last Post: polar
Today 07:44 PM
» Replies: 22
» Views: 2518
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 07:37 PM
» Replies: 305
» Views: 30187
Lumpy Steering - What fluid is best?
Last Post: brodfather11
Today 07:27 PM
» Replies: 4
» Views: 152
brake discs
Last Post: jj9
Today 12:48 PM
» Replies: 1
» Views: 150
Insurance advice after crash
Last Post: Gravity
Today 12:42 PM
» Replies: 6
» Views: 883
Fuse for heater blower
Last Post: painter dave
Today 10:37 AM
» Replies: 1
» Views: 340
battery light
Last Post: painter dave
Today 10:21 AM
» Replies: 0
» Views: 121

[-]
Recent Visitors
Locations of visitors to this page