Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery issues
#1
Hello everyone

I had to leave my 2009 16HDi parked up for a while and on my return the battery was rundown and although the central locking etc worked the can would not start, lack of juice in the battery,   Anyway I charged the battery in situ without disconnecting  it.  Now it starts but the central display is not working and some of the functions are missing.  Any ideas please?

Thank you in anticipation  Huh
Reply
#2
BSI reset?
2010 Berlingo Multispace HDi 110 with FAP.  Persamos green.

Reply
#3
silverfoxHello everyone

I had to leave my 2009 16HDi parked up for a while and on my return the battery was rundown and although the central locking etc worked the can would not start, lack of juice in the battery,   Anyway I charged the battery in situ without disconnecting  it.  Now it starts but the central display is not working and some of the functions are missing.  Any ideas please?

Thank you in anticipation  Huh
Reply
#4
I had the same issue. After BSI reset, charging and re charging no change except increasingly odd symptoms. New battery and all’s well.

Good luck
Reply
#5
You will be okay, what has happened is quite common - like 3rensho says do a search for BSI reset.

Did you get any flashes off the body when you replaced the battery using jump leads?

Check all the fuses if you did

let's start with the easy stuff and see how you get on
[-] The following 1 user says Thank You to polar for this post:
  • silverfox
Reply
#6
My niece has a Peugeot Partner 2.0hdi which she has replaced with a Megane. The Pug has been standing on the yard for 2 months so the battery went flat. I took it off and put it on charge on an 8 amp charger overnight and it was reading 12.55v next morning and the charger had cut out. I took it to the bike shop and put it on their start and charge for another 4 hours and it was showing 12.8v when I took it back. It was refitted and the car started with no weird side effects. Try disconnecting your battery for a while then reconnect it if it's showing a good reading. Anything below 12.5v is borderline.
So where does this bit go then ?
Reply
#7
Checking out a 2015 berlingo van, I noticed that the battery light was flashing when I turned on the ignition. It started up with no problems. Does flashing light means problem with the battery?

Στάλθηκε από το Redmi Note 3 μου χρησιμοποιώντας Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Handbrake or in my case, not !
Last Post: GraemeT
Today 11:06 AM
» Replies: 1
» Views: 238
Diesel Filler Cap
Last Post: brodfather11
Today 07:30 AM
» Replies: 3
» Views: 291
Welding sills
Last Post: cancunia
Today 07:24 AM
» Replies: 8
» Views: 1264
Engine fault STOP Diagnostic
Last Post: cancunia
Today 07:21 AM
» Replies: 1
» Views: 96
Noise from suspension top mount
Last Post: GJB
Today 06:28 AM
» Replies: 28
» Views: 3382
Oil leak XTR 92 Fap
Last Post: Pid
Yesterday 05:45 PM
» Replies: 5
» Views: 1685
Tail lights
Last Post: gazahull
Yesterday 01:37 PM
» Replies: 2
» Views: 697
engine temperature cooling fan
Last Post: Oldfella
Yesterday 10:41 AM
» Replies: 4
» Views: 361
newbie
Last Post: fluidityfreerun
Yesterday 08:33 AM
» Replies: 2
» Views: 335
How rare are the sunroofs?
Last Post: ffrenchie
Yesterday 07:02 AM
» Replies: 1
» Views: 327

[-]
Recent Visitors
Locations of visitors to this page