Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sos noise
#11
Then yes it's easy to pull the stereo out, although you will need a couple of cheap removal tools, Halfords sell them.

By disconnecting the stereo you'll be able to identify if the sound is actually coming from the speakers - if it still happens with the stereo unplugged you'll know there's a separate speaker for the telematics. If the noise stops then it's probably the stereo that's actually generating the sound and it's possibly and issue with the stereo that needs sorting.

You say you've been to a Citroen specialist, problem is they may not actually be any good or may not be that good with the electronic systems. There are good specialists and bad ones.
[-] The following 1 user says Thank You to hawaiianblue for this post:
  • WaqasAli1
Reply
#12
Hi, Thank you i took the stereo out yesterday as i had been busy and the noise still comes whilst driving. I disconnected the wires in the back of the stereo . Thank you

Sent from my SM-G960F using Tapatalk
Reply
#13
so I reckon you've got a telematics unit in the dash somewhere.

Next step would be to take the glovebox out and have a good look up behind there and see if there are any extra electrical boxes. You could also check under the drivers side, (the panel under the steering column pops off easily)
[-] The following 1 user says Thank You to hawaiianblue for this post:
  • WaqasAli1
Reply
#14
I wish i can just bring it to you, You sound like a pro!

Sent from my SM-G960F using Tapatalk
Reply
#15
Struggling to check under neth, Shall i take it to another garage ?

Sent from my SM-G960F using Tapatalk
Reply
#16
I would suggest maybe somewhere that fits alarms, stereos, trackers etc might be a better bet than an ordinary garage.
Reply
#17
maybe disconnect the speakers ?
Reply
#18
All fixed now!! Thank you. I took the glove box out etc found this! Was also a Smart sat nav plugged in. [Image: 5571cba71b5dc1964076d42164736c2b.jpg]

Sent from my SM-G960F using Tapatalk
Reply
#19
(10-01-2019, 03:41 PM)WaqasAli1 Wrote:  All fixed now!! Thank you. I took the glove  box out etc found this!  Was also a Smart sat nav plugged in. 
See, told you.  Wink

Glad it's sorted.

Unplug it all and lob it on eBay. You might even get a free quid for it.
[-] The following 1 user says Thank You to hawaiianblue for this post:
  • WaqasAli1
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Torsion bar
Last Post: jj9
Today 01:11 AM
» Replies: 23
» Views: 1278
Idle speed.
Last Post: benrums0n
Yesterday 10:10 PM
» Replies: 4
» Views: 559
tensioner pulley
Last Post: jj9
Yesterday 08:38 PM
» Replies: 11
» Views: 695
Berlingo vs Nissan
Last Post: Ikanpaul
Yesterday 08:29 PM
» Replies: 0
» Views: 92
Stiff clutch 2.0 hdi
Last Post: polar
Yesterday 07:35 PM
» Replies: 1
» Views: 159
multispace headliner
Last Post: Gadgetman
Yesterday 09:21 AM
» Replies: 1
» Views: 360
New Berlingo Anyone????
Last Post: msw109
20-01-2019 09:54 PM
» Replies: 5
» Views: 857
Berlingo----- Console
Last Post: Satellitemark
20-01-2019 08:53 PM
» Replies: 5
» Views: 981
Partner 3 seat (front) conversion
Last Post: dumdum
20-01-2019 08:33 PM
» Replies: 0
» Views: 177
How did the Berlingo get it's name ?
Last Post: Egg on Leggs
20-01-2019 07:07 PM
» Replies: 15
» Views: 3153

[-]
Recent Visitors
Locations of visitors to this page