Thread Rating:
  • 6 Vote(s) - 3.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The inicators don't stay on.
#1
2003 Berlingo 1.9D

The right is worse than left but basically I have to hold the indicator stalk firmly in position to keep indicating.

Sometimes even then it's hit and miss.

Is it a common problem with an easy fix? (I hope so, haha)

Any advice appreciated.
Many thanks.
Reply
#2
Same thing happened to my MK2 twice.

Have a look at the 'How to get to Berlingo COM 2000 Unit' Thread
woodshaper
Sole Member and President for LIFE!
Reply
#3
Thanks, so do you think I'm going to need new stalks?
Reply
#4
(03-12-2011, 11:56 PM)MattFreeman Wrote:  Thanks, so do you think I'm going to need new stalks?

If remember right the entire unit with the stalks on was replaced by the dealer under warranty, but the same thing happened again not long afterwards when using the left indicator position.
Suspect it was a broken piece in the switch body rather than an electrical one.
It was on an 07 MK2 XTR.

Sure that someone else on the Forum will be able to offer more info.

woodshaper
Sole Member and President for LIFE!
Reply
#5
It's definitely a mechanical problem in the stalk (a piece broken) not an electrical connection issue.
Does anyone know if it's fixable with some ingenuity and some epoxy glue perhaps?

I guess the first thing is to take it all apart.
Does anyone have anything more to offer?
Reply
#6
Solved! I took the covers off (without removing the whole assembly and steering weel) I then gave all the internals a good flooding of contact cleaner (solvent in a spray can) and operated the mechanism 50 or 60 times. Now my indicators stay on and operate perfectly every time. It must have just been some grime/ corrosion on the contact. Happy days!
Reply
#7
Glad to hear it was a simple fix, did you follow the removal tutorial that is on the forum out of interest?
Want Help with the Forum? Read Help Documents Here

Reply
#8
I didn't need to Andre, I just removed the plastic covers which was quite self explanatory.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
1.6 hdi turbo fail again advice please
Last Post: Lighty
Today 06:19 AM
» Replies: 22
» Views: 2776
gearbox removal
Last Post: Art b
Yesterday 11:27 PM
» Replies: 2
» Views: 147
Issue with starts (cold/warm engine)
Last Post: TessG
Yesterday 06:12 PM
» Replies: 16
» Views: 1071
Berlingo sudden lurching and jumping.
Last Post: lien
Yesterday 04:31 PM
» Replies: 7
» Views: 898
Sos noise
Last Post: hawaiianblue
Yesterday 02:15 PM
» Replies: 10
» Views: 1213
Sat Nav 2015 enterprise
Last Post: cancunia
Yesterday 09:45 AM
» Replies: 4
» Views: 681
Hello
Last Post: Matt Haigh
08-12-2018 10:10 PM
» Replies: 1
» Views: 404
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
08-12-2018 09:55 PM
» Replies: 558
» Views: 103916
Switch Purpose ??
Last Post: Oi69
08-12-2018 03:20 PM
» Replies: 16
» Views: 2855
Anti Pollution
Last Post: Jackalus
08-12-2018 03:11 PM
» Replies: 22
» Views: 14917

[-]
Recent Visitors
Locations of visitors to this page