Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] new member needing lots of help
#1
berlingo m59 2007 
had a problem with water in bsi  sent for repair to it was not repairable found used unit set away to clone  came back not working they were very good and sent me a virgin unit 
set it all up with lexia chinese clone all went well van started c/locking worked the only problem was the dash.
all lights on beeping no gauge movement  mileage just a row of dashes and when turned of and key out dash stays on as do headlamps,
after 4 minutes you hear a click bsi sleeps and all lights out . 
fault codes u0028 and p0c11  .
checked wiring  canbus wires at  bsm  has 4.5volts and 2.5 v fluctuating so i presume cam bus is ok  
id desperation striped  can wires along the front  looked ok but i spiced in new wires still the same.
thinking its still a bsi fault i purchased a bsi ,ecu,key kit from zantia all numbers on bsi same ecu model but slight different serial number 
fitted it all on van started and ran but dash still the same 
cleared all codes still the same 
found a used dash fitted it still the same 
i can access the instrument on the lexia and a launch and all work and test good 
looking for wiring diagram for this vehicle  as i only have access to autodata  and the diagrams on that are not good
am i missing something ??? what can keep the bsi awake after turning off?
i have tried bsi reset many time
hazards do not work and heated rear window doesn't work but if i sit in the van and wair until it sleeps and then press the hazard dishe light up headlamp on but no hazzard
anybody come across this problem 

the launch explanation of p0c11 is com fault with engine relay unit ecu 
any help or advise  welcome
Reply
#2
What size engine & fuel?
Reply
#3
1.6 hdi diesel
Reply
#4
The 2.0 uses Siemens & the 1.6 uses Bosch IIRC, there's a good youtube video from HDI tuning about setting up a virgin BSI, but it's for a 2.0, again IIRC. Might be worth taking a look all the same.
When you run the initial Lexia diagnostic scan which goes through the Injection, BSI, ABS etc do you get any errors in the 2 columns on the right?
Reply
#5
have you tried the shunt fuse,its a slightly bigger fuse grey in colour
you take it out and move it across about 5mm put it in to the new position
then do a BSI reset.when you take it out you will see that it looks like a double slot for the same fuse.
Reply
#6
i will try the shunt fuse later
as for faults the only code s are p0c11 po521 (anti scanning)p0636 ext temp sensor p0816 oil temp sensor the code i cannot understand is the p0c11 i just tried to clear them again and when the fault is clearing the dash work and the mileage shows
as soon as code clearing finishes the dash lights up and mileage shows lines again
Reply
#7
(13-04-2019, 12:57 PM)unclebuck Wrote:  i will try the shunt fuse later
as for faults the only code s are p0c11 po521 (anti scanning)p0636 ext temp sensor p0816 oil temp sensor the code i cannot understand is the p0c11 i just tried to clear them again and when the fault is clearing the dash work and the mileage shows
as soon as code clearing finishes the dash lights up and mileage shows lines again



Here's the BSI configuration video I was thinking about.
Does the Lexia 'diagnosis / global test' show any problems in the dialogue or fault columns?
I'm wondering if your instrument cluster is configured properly in the BSI, maybe you could try the actuator tests for the rev counter?

https://www.youtube.com/watch?v=3MV9zTh0C10
Reply
#8
well i tried the shut did not work i can activate the dash panel and it all works fine
Reply
#9
As said in post 5 have you checked the shunt fuse is in correctly? it can be put in wrong.
Are we there yet????? Huh
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#10
yes checked shut fuse is in correct i can activate the gauges and everything through lexia all work
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 09:19 PM
» Replies: 845
» Views: 230887
Looking for a B9 with Modutop
Last Post: ron
Yesterday 08:17 PM
» Replies: 3
» Views: 406
sell up or repair ?
Last Post: Rasputin
Yesterday 08:15 PM
» Replies: 6
» Views: 570
2.0 HDi bottom radiator hose removal?
Last Post: ChefExcellence
Yesterday 08:02 PM
» Replies: 0
» Views: 104
Modutop roof seal, 2006 Desire.
Last Post: cancunia
Yesterday 03:20 PM
» Replies: 1
» Views: 184
Adding seats to the back
Last Post: JOP3L
Yesterday 02:28 PM
» Replies: 3
» Views: 706
Hello , I now own my first Berlingo.
Last Post: markallen5
Yesterday 12:55 PM
» Replies: 0
» Views: 187
2010 1.6L HDI berlingo SOMETIMES wont start
Last Post: diien
Yesterday 03:03 AM
» Replies: 8
» Views: 718
COFUSED .COM
Last Post: polar
20-10-2019 08:19 PM
» Replies: 4
» Views: 405
Hand Priming Pump
Last Post: Lighty
20-10-2019 08:09 PM
» Replies: 5
» Views: 494

[-]
Recent Visitors
Locations of visitors to this page