Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dw8 horrific sounds for miles then cleared !
#1
Been away for a few days with the family in my non turbo diesel, after about 450 miles over 2 days all of a sudden there was a very loud rattle very similar to tapping tappets but worse or knocking bottom end etc ( sounded terminal).

This was on motorway slowing down didn't help and it was whenever I tried to put any load on motor. Decided to limp it home at 60 mph and try not to use accelerator and after 20 odd miles it just cleared! The car never lost power or smoked but I'm convinced it's engine related not box / drivetrain and to me sounded like I imagine an engine about to expire through lack of oil pressure etc sounds.

Been out today everything is normal

Sent from my Moto E (4) Plus using Tapatalk
Reply
#2
I had similar about two months ago , shortly after fuelling .
To me it sounded like "pinking " like you get if the engine timing is out. Like you after twenty miles or so it was back to normal and never reoccurred .

On the 1.9d there is an advance and retard solenoid on the back of the HP pump it may have stuck temporarily and later freed itself.

It was as if it may have been caused by the diesel fuel having a little petrol or kerosene in it or ??????. Certainly couldn't smell any petrol in it
2001 1.9d DW8B  Berlingo
Reply
#3
(16-04-2019, 07:49 AM)brodfather11 Wrote:  I had similar about two months ago , shortly after fuelling .
To me it sounded like "pinking " like you get if the engine timing is out. Like you after twenty miles or so it was back to normal and never reoccurred .

On the 1.9d there is an advance and retard solenoid on the back of the HP pump it may have stuck temporarily and later freed itself.

It was as if it may have been caused by the diesel fuel having a little petrol or kerosene in it or ??????. Certainly couldn't smell any petrol in it
Yeh sounded similar to pinking I've heard in older petrol cars but louder and faster reminded me off my old cvh with hydraulic tappets which would rattle similar on first start.

Fuel makes sense though as when I bought the car about 1500 miles ago it had quarter tank but since I've had it it's never dropped below half apart from said journey. Definitely sounded terminal

Sent from my Moto E (4) Plus using Tapatalk
Reply
#4
Also after servicing etc I'm still getting poor mpg so I'm gonna check the timing as previous owner had belt done

Sent from my Moto E (4) Plus using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Unorthodox methods
Last Post: cancunia
Today 07:34 AM
» Replies: 2
» Views: 230
Front wipers not working
Last Post: ffrenchie
Today 06:46 AM
» Replies: 4
» Views: 455
Weird fan like noise from engine on 1.6 Blue HDi...
Last Post: kingy1912
Yesterday 09:26 PM
» Replies: 2
» Views: 402
Suspension knock
Last Post: labeline
Yesterday 08:46 PM
» Replies: 2
» Views: 225
Towing weight
Last Post: Trevor
Yesterday 06:36 PM
» Replies: 14
» Views: 2915
Another air con problem
Last Post: Peter Palmer
Yesterday 03:05 PM
» Replies: 11
» Views: 2013
Not another Aircon thread
Last Post: Peter Palmer
Yesterday 02:54 PM
» Replies: 2
» Views: 196
random hesitation (increasing frequency) and ESP...
Last Post: Bootlebarth
Yesterday 11:17 AM
» Replies: 0
» Views: 218
battery drains overnight
Last Post: Art b
Yesterday 11:06 AM
» Replies: 20
» Views: 4643
hello all
Last Post: Gadgetman
Yesterday 05:36 AM
» Replies: 7
» Views: 761

[-]
Recent Visitors
Locations of visitors to this page