Thread Rating:
  • 25 Vote(s) - 2.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2.0 hdi turbo fault
#1
Hi guys

new to posting on the forum but have found it very helpful looking up all the little niggles on my 2003 2.0 hdi berlingo workhorse. I have what sounds like an air leak to, or from the turbo, when you go over 2000rpm it spools up ok and can hear it, but there is no boost. Had a look from under the van this morning, is it possible there could be a crack in the plastic pipe between turbo and inlet ? any advice please

thanks Chris
Reply
#2
It more likely that the boost pipe has just come loose. The boost pile is quite hard and unlikely to just crack. There only held on with a soft silicone joiner and a couple of crappy clamps. ( there 60 mm if you replace with jubilee clamp)
Reply
#3
(06-12-2011, 11:04 PM)duamoHDI Wrote:  It more likely that the boost pipe has just come loose. The boost pile is quite hard and unlikely to just crack. There only held on with a soft silicone joiner and a couple of crappy clamps. ( there 60 mm if you replace with jubilee clamp)

hi pal. my 1.6HDi berlingo makes a similar noise. has its just started to do this? mine has always had the noise from new. also im sure that on the 1.6 HDi the turbo is allways being used. its just works along side the engine from low to high Revs to assist the engine.
1.6 HDi Berlingo van , 2011 plate
Reply
#4
hi
thanks for your response, there is definateley a leak or valve stuck open somewhere. No fault lights on dash or black smoke from the exhaust, it just happened suddenly as i was pulling onto the M25. Drove to work today, and it is way down on power, stopped at my local citroen dealer to check availability of the hoses both of which they say are on back order !!
Reply
#5
as suspected duamo hdi, removed boost pipe and silicone top pipe has a small hole in it, nice one, will patch it up till citroen send me a new one
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Snow Tyres
Last Post: Gollycrush
Today 09:32 PM
» Replies: 0
» Views: 22
EML light on - No Fault Code
Last Post: TONX
Today 08:05 PM
» Replies: 0
» Views: 46
No Click from Solenoid
Last Post: Zweli
Today 07:46 PM
» Replies: 0
» Views: 42
How to fit grease nipple on rear axle berlingo
Last Post: jj9
Today 07:11 PM
» Replies: 24
» Views: 8614
What website to pass time over a winters evening...
Last Post: josegar
Today 05:05 PM
» Replies: 5
» Views: 2571
Headlight adjustment
Last Post: Sophiante
Today 05:02 PM
» Replies: 2
» Views: 478
Hi from a me and what to do.
Last Post: cancunia
Today 04:49 PM
» Replies: 3
» Views: 180
2004 alternator not charging
Last Post: Art b
Today 10:58 AM
» Replies: 3
» Views: 547
AUX install for radio
Last Post: ntm1275
Yesterday 10:17 PM
» Replies: 3
» Views: 739
Lowering springs
Last Post: DMaclean
Yesterday 07:28 PM
» Replies: 0
» Views: 301

[-]
Recent Visitors
Locations of visitors to this page