Thread Rating:
  • 25 Vote(s) - 2.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2.0 hdi turbo fault
#1
Hi guys

new to posting on the forum but have found it very helpful looking up all the little niggles on my 2003 2.0 hdi berlingo workhorse. I have what sounds like an air leak to, or from the turbo, when you go over 2000rpm it spools up ok and can hear it, but there is no boost. Had a look from under the van this morning, is it possible there could be a crack in the plastic pipe between turbo and inlet ? any advice please

thanks Chris
Reply
#2
It more likely that the boost pipe has just come loose. The boost pile is quite hard and unlikely to just crack. There only held on with a soft silicone joiner and a couple of crappy clamps. ( there 60 mm if you replace with jubilee clamp)
Reply
#3
(06-12-2011, 11:04 PM)duamoHDI Wrote:  It more likely that the boost pipe has just come loose. The boost pile is quite hard and unlikely to just crack. There only held on with a soft silicone joiner and a couple of crappy clamps. ( there 60 mm if you replace with jubilee clamp)

hi pal. my 1.6HDi berlingo makes a similar noise. has its just started to do this? mine has always had the noise from new. also im sure that on the 1.6 HDi the turbo is allways being used. its just works along side the engine from low to high Revs to assist the engine.
1.6 HDi Berlingo van , 2011 plate
Reply
#4
hi
thanks for your response, there is definateley a leak or valve stuck open somewhere. No fault lights on dash or black smoke from the exhaust, it just happened suddenly as i was pulling onto the M25. Drove to work today, and it is way down on power, stopped at my local citroen dealer to check availability of the hoses both of which they say are on back order !!
Reply
#5
as suspected duamo hdi, removed boost pipe and silicone top pipe has a small hole in it, nice one, will patch it up till citroen send me a new one
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Juddering when pulling away
Last Post: munkey
Today 08:27 AM
» Replies: 3
» Views: 479
starter motor issues
Last Post: malgpz900
Today 08:22 AM
» Replies: 7
» Views: 281
Can i get away with 205/70r15
Last Post: geoff
Today 08:13 AM
» Replies: 6
» Views: 935
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 07:27 AM
» Replies: 702
» Views: 159984
Berlingo 2.0Hdi 2003 multi wont rev past 2000RPM
Last Post: Tree
Today 05:14 AM
» Replies: 3
» Views: 323
Titsup
Last Post: Martinez
Yesterday 07:05 PM
» Replies: 10
» Views: 1252
Hello new member and warning light issues.
Last Post: Jamespworth
Yesterday 06:42 PM
» Replies: 2
» Views: 194
Steel wheels wanted
Last Post: bhcalcutta2
Yesterday 12:05 AM
» Replies: 1
» Views: 334
Can’t find where to plug fault code reader in
Last Post: Martinez
18-04-2019 07:15 PM
» Replies: 2
» Views: 307
tyre wear
Last Post: my mucker
18-04-2019 02:49 PM
» Replies: 4
» Views: 595

[-]
Recent Visitors
Locations of visitors to this page