Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine revving
#1
My 2009 Berlingo with 130k miles on the clock has begun to intermittently rev as if the clutch is slipping but quickly reverts back to normal. There is no smell from the clutch area and it is so infrequent as for me not to be too worried. Is it the clutch or an engine management issue. It is always when I try to accelerate up hill or when I may be in a lower gear than I should be in
Reply
#2
It was the clutch - doh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
air con won't switch off, multispace forte
Last Post: Zion
Today 08:40 PM
» Replies: 7
» Views: 156
2017 Enterprise - Possible to upgrade head unit ...
Last Post: lazy_pete
Today 08:08 PM
» Replies: 2
» Views: 256
LUCAS front CALIPER
Last Post: Zion
Today 07:49 PM
» Replies: 7
» Views: 445
Berlingo enterprise 2016 Central screen
Last Post: joshields@live.co.uk
Today 07:29 PM
» Replies: 0
» Views: 35
Introduction
Last Post: Zion
Today 05:35 PM
» Replies: 8
» Views: 880
K9 van insurance
Last Post: kaney
Today 04:12 PM
» Replies: 2
» Views: 299
AdBlue Topup
Last Post: Zion
Today 03:20 PM
» Replies: 3
» Views: 117
m49 cruise control retrofit............
Last Post: Romahomepete
Today 01:19 PM
» Replies: 11
» Views: 3197
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Zion
Today 12:46 PM
» Replies: 1053
» Views: 338550
Washer pump dead
Last Post: Zion
Today 07:31 AM
» Replies: 8
» Views: 350

[-]
Recent Visitors
Locations of visitors to this page