Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine revving
#1
My 2009 Berlingo with 130k miles on the clock has begun to intermittently rev as if the clutch is slipping but quickly reverts back to normal. There is no smell from the clutch area and it is so infrequent as for me not to be too worried. Is it the clutch or an engine management issue. It is always when I try to accelerate up hill or when I may be in a lower gear than I should be in
Reply
#2
It was the clutch - doh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 08:56 AM
» Replies: 795
» Views: 207999
B9- do they all have DPF??
Last Post: matt1
Today 08:43 AM
» Replies: 0
» Views: 31
2012 Dashboard Speaker Wiring
Last Post: Smaccy
Yesterday 08:23 PM
» Replies: 1
» Views: 378
Heater controls - advice on new part required
Last Post: robjwood
Yesterday 04:35 PM
» Replies: 9
» Views: 1637
Winter tyres c/w steel wheels
Last Post: StuBeeDoo
Yesterday 01:52 PM
» Replies: 0
» Views: 222
Paint - Side door support runner
Last Post: cancunia
Yesterday 10:47 AM
» Replies: 21
» Views: 4865
04 1.9 hdi multisace
Last Post: cancunia
Yesterday 07:10 AM
» Replies: 4
» Views: 1059
New clutch fitted, now reverse lights not workin...
Last Post: John B
24-08-2019 12:38 PM
» Replies: 3
» Views: 578
Hi!
Last Post: John B
24-08-2019 12:33 PM
» Replies: 3
» Views: 711
Headlamps
Last Post: chrisl
24-08-2019 10:50 AM
» Replies: 2
» Views: 730

[-]
Recent Visitors
Locations of visitors to this page