Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ABS light
#1
Hi all. 

Several months ago my ABS light came on. C1331 front right wheel speed sensor signal coherence. I changed the sensor first and the light was still on so then changed the wheel bearing. Light went out perfect!
Several months later and I've just came back after it's been sitting for 5 weeks and as soon as I moved off the ABS light came on again. Same code C1331 so I thought itll be the £7.99 bearing I fitted given up so soon, so I replaced it, light still on. I went and bought a new sensor and the light is still on. 

Any ideas? The ring on the drive shaft looks perfect. 

Thanks
Reply
#2
Maybe it's the wiring for the ABS sensor?
Reply
#3
Check the wiring where is clipped as the wiring can break there
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Risk of filter blocking
Last Post: brodfather11
Today 09:34 AM
» Replies: 1
» Views: 60
HDi AdBlue owners beware
Last Post: berlingoMulti
Today 09:09 AM
» Replies: 17
» Views: 6210
Part number for turbo heat shield mounting fitti...
Last Post: GraemeT
Today 08:26 AM
» Replies: 2
» Views: 179
My 1st Belingo
Last Post: Tomcat3
Today 07:00 AM
» Replies: 2
» Views: 162
Hello!
Last Post: Tomcat3
Today 06:53 AM
» Replies: 1
» Views: 52
Enterprise ICE queries
Last Post: gavthesparky
Today 05:56 AM
» Replies: 0
» Views: 52
2004 gearbox removal difficulty...
Last Post: Art b
Yesterday 10:28 PM
» Replies: 25
» Views: 5840
lower control arm replacement on 55 plate Berlin...
Last Post: geoff
Yesterday 10:16 PM
» Replies: 10
» Views: 721
Juddering when pulling away
Last Post: thestig84
Yesterday 08:56 PM
» Replies: 22
» Views: 5092
Partner Camper Build
Last Post: thestig84
Yesterday 08:51 PM
» Replies: 7
» Views: 1086

[-]
Recent Visitors
Locations of visitors to this page