Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2012 berlingo engine fault
#1
Hi, I have a 2012 Citroen berlingo airstream that keeps coming up with a orange triangle with exclamation mark in the middle and it goes into limp mode also it says on the dash engine fault repair needed. Now this doesn’t come on all the time sometimes it can be a week without a problem then all of a sudden it comes on and sometimes goes back off 5 or so minutes later and sometimes it’s stays on until I turn it off. The van never starts with this fault. One thing I can definitely say is, I have a very steep hill where I live and every time with out fail if I go up this hill when I get to the top and level out this will come on with out fail. 
I have given this van to Citroen who if I’m honest I do not trust them as far as I could throw them. As they told me it needed a new crankshaft sensor as mine had a crack in it, I investigated this and all it that was wrong was the plastic locater had cracked and I’m sure if this was not working properly the vehicle would not start?  I changed it my self and still the same problem. They also told me the rad was leaking and I found that it was the pipe from the header tank to the rad. 
I have been told it could be the battery as this vehicle has paddle shift and that the battery should be changed every 2 years regardless of how good it is ?  I have cleaned the MAF as well. Hope someone can help as I could end up spending £££££££’s trying to find the fault. I have had one diagnostic and they said it was something to do with it sending the wrong oil values so I changed the oil level sensor.
Reply
#2
I know this sounds daft but people in the past on here with a similar fault have found their brake fluid level low. It will cost nowt to check.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
Reply
#3
(24-06-2019, 09:26 PM)Trevor Wrote:  I know this sounds daft but people in the past on here with a similar fault have found their brake fluid level low. It will cost nowt to check.

Hi Trevor, I had heard of this and checked the brake fluid and if anything it has to much. The only thing I haven’t checked is the rear reservoir for the brake fluid. Maybe it’s not very full. Yes it’s grey panel van with everything on it Bluetooth, Aux, USB, paddle shift etc. Thanks in advance for anymore info.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
04 1.9 hdi multisace
Last Post: GJB
Yesterday 05:54 PM
» Replies: 3
» Views: 725
New clutch fitted, now reverse lights not workin...
Last Post: John B
Yesterday 12:38 PM
» Replies: 3
» Views: 390
Hi!
Last Post: John B
Yesterday 12:33 PM
» Replies: 3
» Views: 530
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 11:58 AM
» Replies: 790
» Views: 207117
Headlamps
Last Post: chrisl
Yesterday 10:50 AM
» Replies: 2
» Views: 536
Another air con problem
Last Post: rolf50
Yesterday 09:51 AM
» Replies: 27
» Views: 6967
Drive shaft replacing lower arm
Last Post: ffrenchie
Yesterday 07:01 AM
» Replies: 2
» Views: 385
cruse controle
Last Post: Robban693
23-08-2019 05:34 PM
» Replies: 4
» Views: 368
Suspension knock
Last Post: Lighty
22-08-2019 09:39 PM
» Replies: 9
» Views: 1564
Unlocking - A Problem...SORTED!!!
Last Post: Jed Clampit
22-08-2019 09:05 PM
» Replies: 12
» Views: 2391

[-]
Recent Visitors
Locations of visitors to this page