Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird noise from my 75hp HDi 2009 + Aircon issue
#1
Hi guys, I'm new here.
Basically, as I was driving (40-50km/h, around town), the car started making an awful noise together with a faint vibration. The feeling was as if something was hanging from the car and grinding on the asphalt. The engine temperature went up to 100 deg. celsius, and there was a faint clutch/brake-like smell. After I safely stopped and cut the ignition, the (very) annoying noise persisted for 5-6 minutes. When I popped the hood, I couldn't locate the source of the noise. The best guess I have is the radiator fan, but I'm not the most skilled or knowledgeable mechanic ever. Any help from y'all more experienced guys (and gals) would be very appreciated. 
Plus a (fairly) minor (it would've been minor if it wasn't 40 deg celsius outside) complaint about the A/C
It seems to cool normally when the fan is at 1 or 2, but when I turn it to 3 or 4, the air becomes hot in a few seconds (A/C button pressed all the time, manual A/C). Is this possibly related to the first issue?
Reply
#2
Welcome.
Just guessing... If the noise persisted while you were stopped with the ignition off, chances are that is was the radiator fan as you suspected. Your aircon is probably running low on gas, it will operate down to about 2bar pressure but the lower the pressure, the more the system has to work (making the engine hotter) & the less effective it will be.
[-] The following 1 user says Thank You to cancunia for this post:
  • red.berlingo12
Reply
#3
(03-07-2019, 04:21 PM)cancunia Wrote:  Welcome.
Just guessing... If the noise persisted while you were stopped with the ignition off, chances are that is was the radiator fan as you suspected. Your aircon is probably running low on gas, it will operate down to about 2bar pressure but the lower the pressure, the more the system has to work (making the engine hotter) & the less effective it will be.

Thanks a lot dear sir!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
04 1.9 hdi multisace
Last Post: GJB
Yesterday 05:54 PM
» Replies: 3
» Views: 725
New clutch fitted, now reverse lights not workin...
Last Post: John B
Yesterday 12:38 PM
» Replies: 3
» Views: 390
Hi!
Last Post: John B
Yesterday 12:33 PM
» Replies: 3
» Views: 530
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 11:58 AM
» Replies: 790
» Views: 207117
Headlamps
Last Post: chrisl
Yesterday 10:50 AM
» Replies: 2
» Views: 536
Another air con problem
Last Post: rolf50
Yesterday 09:51 AM
» Replies: 27
» Views: 6967
Drive shaft replacing lower arm
Last Post: ffrenchie
Yesterday 07:01 AM
» Replies: 2
» Views: 385
cruse controle
Last Post: Robban693
23-08-2019 05:34 PM
» Replies: 4
» Views: 367
Suspension knock
Last Post: Lighty
22-08-2019 09:39 PM
» Replies: 9
» Views: 1563
Unlocking - A Problem...SORTED!!!
Last Post: Jed Clampit
22-08-2019 09:05 PM
» Replies: 12
» Views: 2391

[-]
Recent Visitors
Locations of visitors to this page