Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] Power steering has disappeared !
#1
Hi. My steering has gone stiff suddenly. The power steering appears not to working . Cant see any leaks around servo. The clutch Seems ok. The fluid is topped up. Anyone got any clues as to what it may be?
Reply
#2
You are talking about the power steering but then referring to the servo & clutch.

The fluid reservoir that is fixed to the servo is for the brakes and the clutch if the clutch is hydrolic.

The power steering has it's own reservoir, check the level of power steering fluid in that.


.
My vehicle .... 2006 (m59) Berlingo Multispace Desire - 1.6 HDI 92 
Reply
#3
Power steering top up is in front of the engine. If it is still full check the belt has not broken. Is the battery light going out ?
So where does this bit go then ?
Reply
#4
How about the U/J joint that connects the upper steering shaft to the bit that comes up out of the steering rack. That may be getting a bot old and grotty (like me) - see if blasting it with brake cleaner or some other solvent and then regreasing it helps


Our cars  2008 1.6  92 Berlingo (His) RIP 2019
              2008 1.6  110 Mini (Hers)
              2008 1.4  70 207 (Sprogs) RIP 2019
              2010 2.5 Subaru Outback (His)
Reply
#5
(06-07-2019, 07:09 PM)GraemeT Wrote:  How about the U/J joint that connects the upper steering shaft to the bit that comes up out of the steering rack. That may be getting a bot old and grotty (like me) - see if blasting it with brake cleaner or some other solvent and then regreasing it helps

Same thing happened to mine, if the aux belt & fluid level for the power steering are looking good, the UJ is worth a check. I had to jack up both front wheels, spray on plenty of WD40 turn the steering both ways lots of times until it came free then re-greased with chain spray. The chain spray alone would not fix the problem as the old gunge needs to be cleared first.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Key fob help please!
Last Post: MB15
Today 10:37 PM
» Replies: 3
» Views: 165
Oil Leaking from bell housing
Last Post: MB15
Today 10:29 PM
» Replies: 0
» Views: 20
inside roof nets.
Last Post: theraginganarchist
Today 09:48 PM
» Replies: 6
» Views: 2240
Big enough to sleep in with front seats up?
Last Post: theraginganarchist
Today 09:28 PM
» Replies: 16
» Views: 2248
Accident yesterday
Last Post: saskak
Today 08:55 PM
» Replies: 20
» Views: 9682
Replacement Berlingo popup roof skirt
Last Post: Surfchickkelly
Today 07:55 PM
» Replies: 5
» Views: 318
Electronic problem
Last Post: Zion
Today 04:18 PM
» Replies: 6
» Views: 558
BSI fried?
Last Post: Zion
Today 02:18 PM
» Replies: 5
» Views: 398
gear box probs
Last Post: mickrochip
Today 10:05 AM
» Replies: 3
» Views: 342
Wiring trailer lights without factory trailer pr...
Last Post: Amac
Yesterday 10:59 AM
» Replies: 5
» Views: 1372

[-]
Recent Visitors
Locations of visitors to this page