Thread Rating:
  • 21 Vote(s) - 1.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hard to start but runs fine when started
#1
Hiya all again ive a 53 plate beringo Thk dw8 engine

Well just recently its been a pain to start when started it runs perfect allday without fault covered 500 miles this weekend in it

Ive changed fuel filter and checked for any leeks but cannot seem to find any

Im having to prime pump under engine to get it going in the morning before this it was perfect i just cant understand whats happened to it any advice would be Great

Thanks all Muply
Reply
#2
How old are the glow plugs?

Have you had a look at the connectors to them to make sure they are clean and there's no damage?
Reply
#3
Sounds just like some of your glow plugs need replacing. It is typical for the Berl to be a hard start first thing if some need replacement, especially since with the temperature dropping.
Want Help with the Forum? Read Help Documents Here

Reply
#4
iv e got same problem with mine glowplugs changed for new ones and checked they all workin but bein a real pig to start once started runs fine !
Reply
#5
Unsure how old glowplugs are but i will check today and get back to you all Many Thanks
Reply
#6
My wife's corsa diesel was playing up and two of the glow plugs were black, one was a little loose and the connectors to them were crusty and rusty.

changed the plugs and cleaned up the connectors with contact cleaner and it's been spot on ever since.

Either way, it's worth doing for the price of a set of plugs.
Reply
#7
Will have a good look the weekend or hopefully sooner just so cold outside Just another quickie when my berlingo gets just before fuel light its naughty power loss cutting out and just sluggish this is the reason i changed fuel filter any body else suffer from this or is it just me apart from these things its good as gold Thanks in advice Lads
Reply
#8
mines same engine mate,
had exact same problem, black coming from exhaust after a struggle to start.
Changed glowplugs and battery as battery been on the blink too, and now starting perfect, but it would work all day fine, starting and stopping, just first start of every morning. Really easy to replace on that engine too.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
How to fit grease nipple on rear axle berlingo
Last Post: cancunia
Today 09:13 AM
» Replies: 23
» Views: 8163
AUX install for radio
Last Post: ntm1275
Yesterday 10:17 PM
» Replies: 3
» Views: 603
Lowering springs
Last Post: DMaclean
Yesterday 07:28 PM
» Replies: 0
» Views: 155
How to check if the back axle is shot !!
Last Post: geoff
Yesterday 12:44 PM
» Replies: 23
» Views: 33087
Central locking problem
Last Post: Art b
Yesterday 09:55 AM
» Replies: 4
» Views: 448
Headlight adjustment
Last Post: ffrenchie
Yesterday 07:14 AM
» Replies: 1
» Views: 307
Windscreen Arm Linkage keeps Popping Off
Last Post: polar
Yesterday 05:05 AM
» Replies: 6
» Views: 348
2004 alternator not charging
Last Post: Art b
21-09-2018 10:06 PM
» Replies: 2
» Views: 397
NEW USER ELIANO, NEEDS HELP ON GENERAL CHAT
Last Post: Gadgetman
21-09-2018 09:20 PM
» Replies: 11
» Views: 4628
Another Newbie
Last Post: geoff
21-09-2018 08:21 PM
» Replies: 3
» Views: 282

[-]
Recent Visitors
Locations of visitors to this page