Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
P0171 System Too Lean
#1
P0171 System Too Lean (Bank 1)

Van just threw this code on the motorway. Engine doesn't seem to be any different (not obviously rough etc.) so hoping it's just a bad sensor or something.

I had also put in some fuel injector cleaner stuff, so possibly that's revealed a fault or clogged the fuel filter with gunk, or something?

Advice appreciated - on googling, I can't find any posts about this code on a Berlingo specifically..?

1.6 Petrol, btw
Reply
#2
Check the coolant temp (lean will run hot), check the spark plug electrode colour to see if white or brown. Maybe change the fuel filter in any case.

Maybe the MAF?
https://www.obd-codes.com/p0171
Reply
#3
What does the spark plug electrode colour indicate? I was under the impression that a bit of brown was normal..?

Yeah I was planning to change the fuel filter anyway, no record of when it was last changed so assuming it's overdue.

Stupid question, but does the petrol Berlingo even have an MAF? I can't find any reference to it in Haynes or parts websites.
Reply
#4
(12-10-2019, 12:46 PM)SteakAndAle Wrote:  What does the spark plug electrode colour indicate? I was under the impression that a bit of brown was normal..?

Yeah I was planning to change the fuel filter anyway, no record of when it was last changed so assuming it's overdue.

Stupid question, but does the petrol Berlingo even have an MAF? I can't find any reference to it in Haynes or parts websites.

Brown is normal on the plug, so if it's white it's too lean, or black is too rich. No idea about the MAF on a petrol engine, it was just what I read in the link I pasted. Looks in any case to be the oxygen sensor in the exhaust that's complaining, another possibility is maybe that's failed.
Reply
#5
Ah, OK.

I cleared the code before heading home today and it didn't reappear (~140 miles). I'll change the fuel filter as planned and have a look at the lambda sensor while I'm under there anyway.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Rear Abs?
Last Post: weegreenvan
Today 09:56 AM
» Replies: 2
» Views: 290
Instrument panel problem.
Last Post: The Freeman
Today 08:38 AM
» Replies: 0
» Views: 30
Hi folks
Last Post: edwardio
Yesterday 11:05 PM
» Replies: 0
» Views: 139
Night heater
Last Post: Dave Preston
Yesterday 09:17 PM
» Replies: 10
» Views: 4165
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:34 PM
» Replies: 961
» Views: 273952
Rear 2 door berlingo wiper blade
Last Post: andyneile
Yesterday 07:33 PM
» Replies: 0
» Views: 100
Hello
Last Post: geoff
Yesterday 05:58 PM
» Replies: 2
» Views: 291
BSI reset, battery drain
Last Post: geoff
Yesterday 05:55 PM
» Replies: 1
» Views: 201
rear wiper
Last Post: cancunia
Yesterday 04:23 PM
» Replies: 1
» Views: 142
Club Stickers Available
Last Post: cancunia
Yesterday 08:46 AM
» Replies: 43
» Views: 29459

[-]
Recent Visitors
Locations of visitors to this page