Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
COMM Coding?
#1
Hi,

I'm the dufus who pulled his steering wheel off and snapped the horn cable clean off to try and solve a windscreen wiper problem - long story. I've soldered this back together and reassembled but nothing seems to be working on the horn end of things and also now have an airbag light. Hurrah.

I guess I've damaged both cables elsewhere, not that I can see anything. What's my best course of action in this situation?

Assuming the clock spring wires can't easily be repaired from the COMM unit end, what's the deal with getting a second hand (matching part number) entire unit, does that need coding or something?

Thanks in advance.
Reply
#2
No idea on the COMM but you could always fit a dash mounted button and reroute the wiring? Something like:
https://i.ebayimg.com/images/g/BmAAAOSw6...s-l640.jpg

Maybe not ultra elegant but satisfies the MoT man (long story here too involving steering wheel on a Land Rover product) Dodgy
Reply
#3
(16-11-2019, 06:35 PM)GraemeT Wrote:  No idea on the COMM but you could always fit a dash mounted button and reroute the wiring? Something like:
https://i.ebayimg.com/images/g/BmAAAOSw6...s-l640.jpg

Maybe not ultra elegant but satisfies the MoT man (long story here too involving steering wheel on a Land Rover product) Dodgy

Cheers, but I only need this thing to have no dashboard lights and a working horn so I can part ex it somewhere.
Reply
#4
I'm not certain, but I've never heard that the COM2000 needs to be coded. In case it does, it should be possible via Diagbox which does not cost too much to buy these days. It may just be the clock spring that's broken?
You can track the part numbers down via service.citroen.com or catcar.info
https://www.catcar.info/citroen/?lang=en&l=
Reply
#5
(17-11-2019, 08:30 AM)cancunia Wrote:  I'm not certain, but I've never heard that the COM2000 needs to be coded. In case it does, it should be possible via Diagbox which does not cost too much to buy these days. It may just be the clock spring that's broken?
You can track the part numbers down via service.citroen.com or catcar.info
https://www.catcar.info/citroen/?lang=en&l=

Thanks everyone.

It is (or would most likely be) the clock spring wires that I've broken yes, but I can get a 2nd hand part number matched COMM unit for around £75, which (if it doesn't need coding)| should just be a swap out - provided the clock spring on the replacement unit hasn't been swizzled around from straight ahead.

Having looked at the unit I can't see how it could easily have the clock spring repaired though.

I'm reasonably happy to spend £75 for my incompetence, but if it needs coding at a dealer for £80 more then I'd be more reluctant.

Assuming the airbag light should have gone out once I'd plugged it back in again? Doesn't need resetting or anything?
Reply
#6
(17-11-2019, 10:41 AM)Wuffles Wrote:  Assuming the airbag light should have gone out once I'd plugged it back in again? Doesn't need resetting or anything?

IIRC from disconnecting the seat airbags on my M59, the airbag light will reset itself, there are other posts on here about the airbag light and bad connections under the seat with no mention of needing to get the system reset. Best practice will be to disconnect the battery about 30 mins before you start.
Reply
#7
(17-11-2019, 11:21 AM)cancunia Wrote:  
(17-11-2019, 10:41 AM)Wuffles Wrote:  Assuming the airbag light should have gone out once I'd plugged it back in again? Doesn't need resetting or anything?

IIRC from disconnecting the seat airbags on my M59, the airbag light will reset itself, there are other posts on here about the airbag light and bad connections under the seat with no mention of needing to get the system reset. Best practice will be to disconnect the battery about 30 mins before you start.

I'd already done all that, that's why I think there's an invisible break in both cables causing the horn not to work and airbag light to stay on.

Edit to say, because the horn worked and the airbag light wasn't on before I wrecked it.
Reply
#8
The comms unit doesn’t need coding.
In the unlikely event of it having a steering angle sensor fitted, these need to be reset to the straight ahead position, but I doubt yours will have it.
It is vital,that you have the clock spring in the central position before fitting ( and also you wheels)
There is a little window on the back of it to show if you have it straight.
Compare with your old one after you have removed it.
Reply
#9
I'd sent my old unit off for a part ex against a reconditioned unit, so this problem is now "fixed". I had managed to destroy the ribbon cable within the clock spring unfortunately.

I'll start a new thread for the problem that caused all of this in the first place. Thanks for everyone's input.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Mirror cap replacement
Last Post: Pedronicus
Yesterday 09:26 PM
» Replies: 4
» Views: 385
New member in Scotland
Last Post: Stretch
Yesterday 08:51 PM
» Replies: 0
» Views: 75
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Yesterday 08:17 PM
» Replies: 1041
» Views: 336171
Clicking from fuel pump area
Last Post: Stretch
Yesterday 08:04 PM
» Replies: 2
» Views: 199
Sliding door handle
Last Post: kaney
Yesterday 07:14 PM
» Replies: 1
» Views: 474
Hola a todos!
Last Post: Mike
Yesterday 05:47 PM
» Replies: 3
» Views: 285
Radiator fan cycling on / off every few seconds ...
Last Post: Berlingboy
Yesterday 01:53 PM
» Replies: 7
» Views: 569
Wiring trailer lights without factory trailer pr...
Last Post: Berlingboy
Yesterday 01:35 PM
» Replies: 7
» Views: 1749
da.Nm vs. m.daN torque settings
Last Post: saskak
Yesterday 12:26 PM
» Replies: 3
» Views: 151
Citroen-Shop.eu
Last Post: Pedronicus
Yesterday 11:48 AM
» Replies: 0
» Views: 92

[-]
Recent Visitors
Locations of visitors to this page