Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electric failure
#1
Hi, Is it someone who have a proper wiring diagram for a petrol berlingo year 2000? I need diagram for Fuelinjection and ignition

and is ignition sytem integrated in same box as fuelinjection?

Reason is Earth over fuelpump fuse when it should be ignition plus  And No Spark, No Power, to injector  Maybe broken ecu for fuelinjection? immobiliser seems to registrate key and fuel cut off(red button) works and are measuredHuh
Reply
#2
Maybe the Haynes manual would help?
I think there are other links on here, but this one should work...
https://www.berlingoforum.com/thread-142...l#pid91767
[-] The following 1 user says Thank You to cancunia for this post:
  • Ron984
Reply
#3
(06-12-2019, 10:33 AM)cancunia Wrote:  Maybe the Haynes manual would help?
I think there are other links on here, but this one should work...
https://www.berlingoforum.com/thread-142...l#pid91767
Thanks for help but sadly it wasn't any information about fuelinjectionsystem or ignition! i need to measure all pin on injection ecu
Reply
#4
Haynes have a book...
'Professional Techbook' 3558
Engine Management and Fuel Injection Systems
Pin Tables andWiring Diagrams
Volume 1 - Alfa Romeo to Mazda

Chapter 5 is all about Citroën.
But there's 16 wiring pinouts and wiring diagrams...
I could try to see if I can find something if you have the make and model of the ECU.
[-] The following 1 user says Thank You to Gadgetman for this post:
  • Ron984
Reply
#5
(07-12-2019, 11:19 PM)Gadgetman Wrote:  Haynes have a book...  
'Professional Techbook' 3558
Engine Management and Fuel Injection Systems
Pin Tables andWiring Diagrams
Volume 1 - Alfa Romeo to Mazda

Chapter 5 is all about Citroën.
But there's 16 wiring pinouts and wiring diagrams...  
I could try to see if I can find something if you have the make and model of the ECU.
I think i found right one!  but there is somthing more wrong as maybe related to this! rear window heat is dead no power and also no power to heating fan but fuse is still okay! if i draw a separate cable to + it works! but citroen cable color is totally amazingly bad ! and no iso logic! as Green and brown is sometime + wich is total idiotic they maybe have red for coold water in france? Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BSI reset, battery drain
Last Post: goodbyebri
Today 12:26 PM
» Replies: 2
» Views: 227
Interior light not coming on when I open the doo...
Last Post: Scotland1976
Today 12:08 PM
» Replies: 6
» Views: 123
Bloody bleeding brakes!
Last Post: ffrenchie
Today 11:43 AM
» Replies: 11
» Views: 461
Rear washer jet blocked
Last Post: SteakAndAle
Today 11:03 AM
» Replies: 0
» Views: 23
Instrument panel problem.
Last Post: brajomobil
Today 09:21 AM
» Replies: 3
» Views: 273
Amdro Boot Jump with for Sale
Last Post: Ginny
Yesterday 10:29 PM
» Replies: 2
» Views: 903
Hi folks
Last Post: edwardio
Yesterday 04:46 PM
» Replies: 2
» Views: 409
Front clunking
Last Post: Zcarz
Yesterday 01:39 PM
» Replies: 0
» Views: 199
rear wiper
Last Post: oleolegua
Yesterday 01:24 PM
» Replies: 2
» Views: 319
Rear Abs?
Last Post: weegreenvan
Yesterday 09:56 AM
» Replies: 2
» Views: 508

[-]
Recent Visitors
Locations of visitors to this page