Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Notchy" Power Steering
#1
Hi
2.0HDi 2005 Multispace

So ive got a weird "notchy" feel to the steering, obviously on bends it feels like it stops power for a millisecond a few times as you hold the angle into the corner, seems to be more on right turns but still on left turn too, slower turns give greater twitches than fast bends

I would say low PAS fluid but its not !!??

Any ideas please ?
TIA
Reply
#2
Hi, welcome to the forum.
Chances are it's the UJ at the bottom of the steering shaft. If you search around on here there are some threads about easing the joint. Basically, get both front wheels off the ground, free the joint with WD40 or similar while turning lock to lock a few times, then repeat with some spray grease.
[-] The following 1 user says Thank You to cancunia for this post:
  • boltonboy
Reply
#3
Thank You I will try that and report back
Cheers
Reply
#4
The other basic and cheap item is renewing the PS fluid ..... I use a big syringe to pull the fluid out of the reservoir, others use a washing up liquid bottle with a pipe on the end etc etc.

Remove a good slug of fluyid and fill back up.

After a day or so driving around repeat then repeat again and you may well have a result.

Another one - drive onto some cardboard ( or a muddy verge ) - and work the steering wheel fully lock to lock a few times this may also give a good result.
Reply
#5
Hello - had something similar - hold steering wheel lightly on  a bend and the steering wheel oscillates back and forth. Grip it hard and you can feel the movement but not see it. This was tracking in our case. Try the fluid first though (its cheaper) :-)


Our cars  2008 1.6  92 Berlingo (His) RIP 2019
              2008 1.6  110 Mini (Hers)
              2008 1.4  70 207 (Sprogs) RIP 2019
              2010 2.5 Subaru Outback (His)
Reply


Forum Jump:


Users browsing this thread: goodbyebri, 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BSI reset, battery drain
Last Post: goodbyebri
Today 12:26 PM
» Replies: 2
» Views: 227
Interior light not coming on when I open the doo...
Last Post: Scotland1976
Today 12:08 PM
» Replies: 6
» Views: 123
Bloody bleeding brakes!
Last Post: ffrenchie
Today 11:43 AM
» Replies: 11
» Views: 461
Rear washer jet blocked
Last Post: SteakAndAle
Today 11:03 AM
» Replies: 0
» Views: 23
Instrument panel problem.
Last Post: brajomobil
Today 09:21 AM
» Replies: 3
» Views: 273
Amdro Boot Jump with for Sale
Last Post: Ginny
Yesterday 10:29 PM
» Replies: 2
» Views: 903
Hi folks
Last Post: edwardio
Yesterday 04:46 PM
» Replies: 2
» Views: 409
Front clunking
Last Post: Zcarz
Yesterday 01:39 PM
» Replies: 0
» Views: 199
rear wiper
Last Post: oleolegua
Yesterday 01:24 PM
» Replies: 2
» Views: 319
Rear Abs?
Last Post: weegreenvan
Yesterday 09:56 AM
» Replies: 2
» Views: 508

[-]
Recent Visitors
Locations of visitors to this page