Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NO HORN !!
#1
Hello again, having successfully solved the poor starting problem by changing to a new starter motor I have since gained a non-working horn! This is a recurring problem first solved when the mechanic had to move certain cables to replace the starter motor thus disturbing the earth lead presumably. I have now followed the advice of several posters and performed the trick of re-earthing from the base of the steering column to the bulkhead with success. I have tested for possible fault codes coming on and so far all is good. Fingers crossed that this is a pemanent fix! Thanks go to all who suggested this simple fix previously.[Image: smile.png]
Reply
#2
yup the earth can be a problem..
with mine a BSI reset fixed it

2004 ,1.9d Berlingo Multispace.
called Brian... Smile
Reply
#3
I'm having same thing with the horn but my main dealer hasn't fixed it ?? that and all the other things wrong or not working makes for a sad customer ?
[-] The following 1 user says Thank You to Disheartened for this post:
  • Art b
Reply
#4
(18-01-2020, 06:24 AM)Disheartened Wrote:  I'm having same thing with the horn but my main dealer hasn't fixed it ?? that and all the other things wrong or not working makes for a sad customer ?

The horn seems to be a real issue on berlingos. I've had 2 go and the only way I could get around it was either Re earthing it like the person above did and on the other I put in a separate horn.

I think the problem is under the air bag in the wheel but I'm not into removing air bags so I just earth it for the Mot which just about gets it through. Then I rip it all back out because there's no decent way I can find to do a permanent earthing.
Reply
#5
same problem....can some one put up pics of the earth off steering column plz
[-] The following 1 user says Thank You to Wellmound for this post:
  • Art b
Reply
#6
(13-02-2020, 01:00 PM)Wellmound Wrote:  same problem....can some one put up pics of the earth off steering column plz

you can put an earth clamp,
 on the base of the column,earthed to the body ..

2004 ,1.9d Berlingo Multispace.
called Brian... Smile
Reply
#7
Hi guy untill today i couldnt get the horn...i took airbag off tested everythin it all worked fine...even live from the wheel to airbag...so i tweeked the little tangs on the air bag...now i have good horn...gope this helps as iv not see anyone suggest tweeking the connector tangs......
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
After Market Rear Camera Bracket
Last Post: Zion
Yesterday 10:33 PM
» Replies: 1
» Views: 164
7 Inch Touchscreen Navigation Option
Last Post: Zion
Yesterday 10:28 PM
» Replies: 5
» Views: 411
display fading (MFD B, not bulb related)
Last Post: mikeB
Yesterday 04:57 PM
» Replies: 58
» Views: 20542
NO HORN !!
Last Post: Wellmound
Yesterday 02:09 PM
» Replies: 6
» Views: 959
Engine Management System warning light then limp...
Last Post: Zion
Yesterday 11:35 AM
» Replies: 1
» Views: 240
abs trouble
Last Post: Zion
Yesterday 11:30 AM
» Replies: 13
» Views: 1435
My Berlingo
Last Post: Zion
Yesterday 09:10 AM
» Replies: 3
» Views: 1030
Hi
Last Post: smith335
21-02-2020 07:09 PM
» Replies: 1
» Views: 437
Fitting a motorbike
Last Post: gixer1k8
21-02-2020 06:31 PM
» Replies: 5
» Views: 887
Peugeot Partner 2.0 HDI
Last Post: jorgebustas
21-02-2020 02:21 PM
» Replies: 5
» Views: 2651

[-]
Recent Visitors
Locations of visitors to this page