Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi folks
#1
Hi folks, just joined the forum years after i bought my 2004 Berlingo 1.9D...it's an ex utility vehicle and has been wonderful to me for 5 years now...i'm currently at 115k miles and everything works fine except for the fan blower heater...
I hope by joining i can resolve my issue as i'm bloody freezing lol...

Thanks again
Reply
#2
Welcome aboard..

2004 ,1.9d Berlingo Multispace.
called Brian... Smile
Reply
#3
I love it when a plan comes together I feel like a boss after that job, took out the old blower motor went to the scrapyard, got another one for 15 quid put it back in bobs your uncle.. happy as a pig in truffle oil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Window stops engine!
Last Post: Chocolate teaspoon
Today 08:44 PM
» Replies: 9
» Views: 855
Roof Seal
Last Post: JobandBoyce
Today 08:24 PM
» Replies: 7
» Views: 671
Alternator woes
Last Post: AnthonyExeter
Today 06:52 PM
» Replies: 8
» Views: 363
Orange Triangle
Last Post: skeeterm5
Today 06:03 PM
» Replies: 3
» Views: 301
Reversing sensors
Last Post: Rosie007
Today 03:21 PM
» Replies: 0
» Views: 84
ICE Head Unit Recommendations Please
Last Post: Matt Haigh
Today 10:32 AM
» Replies: 0
» Views: 141
Blower resister
Last Post: Kevin1841
Today 10:11 AM
» Replies: 0
» Views: 132
Heat damaged loom
Last Post: Soarer
Today 08:31 AM
» Replies: 4
» Views: 364
Logic is a myth
Last Post: Zion
Yesterday 07:10 PM
» Replies: 17
» Views: 917
Fan in front of radiator stopped working
Last Post: thomasselboe
Yesterday 05:42 PM
» Replies: 2
» Views: 398

[-]
Recent Visitors
Locations of visitors to this page