Thread Rating:
  • 16 Vote(s) - 2.44 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Worn top mounts maybe???
#1
The issue is this.

If moving slowly say in traffic and the brake is applied quickly and sharply, there is a knock noise and the feel of some sort of play in the front of the van.

I have had droplinks and wishbones replaced and everything is fully tight.

I thought it might be play in the suspension strut somewhere. Has anyone got anymore pointers
Reply
#2
(17-12-2011, 01:54 PM)800HDI Wrote:  The issue is this.

If moving slowly say in traffic and the brake is applied quickly and sharply, there is a knock noise and the feel of some sort of play in the front of the van.

I have had droplinks and wishbones replaced and everything is fully tight.

I thought it might be play in the suspension strut somewhere. Has anyone got anymore pointers

i have just recently found the cause of my knocking after looking for it a thousand times.i had the front springs replaced after one had snapped.i found the clown that had done it had not seated the bottom of the suspension leg correctly the little lug should be between the clamp bolt.this resulted in the top of the suspension leg banging on the inner wing on both sides.since seating them i have no knocking.i never thought to check after a so called mechanic had fitted the springs!!!
it may be worth checking the work you have already had done !

Reply
#3
(18-12-2011, 09:10 AM)lorraine Wrote:  i never thought to check after a so called mechanic had fitted the springs!!!
it may be worth checking the work you have already had done !

Mechanics !!!!! I have s**t 'em !!!!!

Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#4
All work done ok as did it all myself lol.

May have to get out in the snow and start looking
Reply
#5
Worn wishbone bushes. Had a breaker bar on the wheel nut today and found the strut moved left to right about 5 mm.

So called good quality cheap replacent wishbones from ebay. Never again, 16 months old with 9k miles on them.

Been bitten by getting cheap parts!!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
2003 2.0 HDI Poor fuel consumption
Last Post: Norfolkboy
Today 12:07 PM
» Replies: 32
» Views: 8693
airbag stolen - is it a thing
Last Post: rapidyellow
Today 10:39 AM
» Replies: 3
» Views: 535
EGR valve
Last Post: cancunia
Today 10:19 AM
» Replies: 1
» Views: 54
Twitter or Facebook @BerlingoForum
Last Post: saskak
Today 09:49 AM
» Replies: 45
» Views: 11289
Cruise control - phone a friend?
Last Post: cancunia
Today 08:26 AM
» Replies: 1
» Views: 194
Rear Hub Nut Size
Last Post: MadDog
Today 08:26 AM
» Replies: 3
» Views: 525
Grizz' Prozac for the Soul - Berlingo Multispace
Last Post: Grizz
Today 07:50 AM
» Replies: 681
» Views: 149562
What brand/model oil filter 1.6 hdi
Last Post: cancunia
20-03-2019 11:19 AM
» Replies: 7
» Views: 2563
puff of blue-ish smoke on startup
Last Post: saskak
20-03-2019 11:09 AM
» Replies: 10
» Views: 758
2004 alternator not charging
Last Post: Art b
20-03-2019 08:21 AM
» Replies: 7
» Views: 1949

[-]
Recent Visitors
Locations of visitors to this page