Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help! No lights on dashboard 2003 Berlingo 2.0Hdi
#1
Whilst fixing the electric window switch that had disappeared into the dashboard (put it back in correctly rather than the bodge job the parrot fitter did and added electrical tape to the outside to try to stop it from disappearing again), I installed a new sony cd radio at the same time with the connection kit from Dynamic Sounds. At first I had lights on the cd player without the ignition switched on with I believe all of the cables in the right places (i.e. red/yellow connected to the corresponding colour. At this time I discovered I hadn't connected the aerial lead, so did so. Then the sony unit made 3 beeps and turned off. I tried the ignition to see if it would turn back on but no signs of life and no lights on the instrument panel or display on the dash. I then reconnected the old stereo to see if it was something to do with this, this made some cd loading sounds (no cd in it) but still no lights on dash/instrument panel.

I tested the hazard lights and no flashing on the intstrument panel, same with headlights and indicators yet they were on and working.

Have found one fuse and checked that, just spotted another fuse to check so will do that in the morning when not so hot. If it's not that then will see if my friendly mechanic can have a look at it for me when he has a moment (observing social distancing of course!). Luckily not using car much at the moment other than to take my daughter to her dads fortnightly and so don't need to go there again until next week. Just frustrating as I've fitted lots of stereos in the past with no problem (other than a dodgy aerial connection on one) and was trying to save some money doing it myself as I'm not completely incapable of plugging wires into each other but this one has me stumped!
       
Reply
#2
I am sure that I recall a long time ago some chat on here about the need to swap the red and yellow wires over when installing a non Citroen radio. If you think about doing this PLEASE check that what I say is correct.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
Reply
#3
Thanks, I'll investigate the red & yellow wires. Would this affect the Parrot bluetooth that is also installed do you think?
Reply
#4
The standard radio wiring is in the handbook, if you don't have one, you can download it from the forum.
Here's the link:
http://berlingoforum.com/Citroen%20Berli...ndbook.pdf

No lights on the instrument panel suggests that you may have a blown fuse or loose connection, the fuses are also listed in the handbook. I'd start by taking the radio out and check all the fuses.
Reply
#5
I've checked fuse 4 and fuse 15 again this morning, 4 is fine and 15 is blown. So new fuses ordered as no spares in my dad's shed (lots of other things but no spare fuses unfortunately).

Thanks for the handbook, will check the radio connectors and see if I can work out the red/yellow conundrum bearing in mind I also have the parrot connected...
Reply
#6
The red and yellow thing, one is for permanent live to maintain station selection and settings, the other is ignition live to turn the stereo on. If they're the wrong way round it will forget the tuning and settings every time you turn the ignition on, but would still function.

If it does act like new each time you turn it on, swap those two wires round, connect red to yellow and yellow to red. They usually have bullet connectors to facilitate this.

The parrot kit should not interfere except it would have been connected into the AUX and speaker wires on the original stereo so it can interrupt the radio when a call is received.
My Van: 2012 B9 1.6 HDi Enterprise 
Reply
#7
Thanks all, I have just fitted a new fuse (after speaking nicely to my friendly mechanic next door) and the dashboard lights are back - hoorah!

Swapped the yellow/red cables to yellow-red rather than yellow-yellow/red-red and stereo works fine with memory working. However, to turn it off it's a case of removing the faceplate/pressing the off switch when the ignition is off. Haven't tried it with yellow-yellow/red-red to see if that works - next on the list but first time for lunch!
Reply
#8
Tested swapping the red/yellow cables over and it leads to the unit not retaining memory settings when ignition is switched off.

Swapped back and tested again with cables on yellow/red cross pairings again and it retained memory settings. I then worked out I needed to set the Autooff on the radio to a time limit, so set to 30seconds and tested and worked perfectly. Happy with that.

Still can't get the stalk controls to work even with the connector from Dynamic sounds but that's a job for another day, I can cope with pressing buttons on the radio. Also tested my parrot kit to make sure that was still working and it does - hoorah again!

Betty Bingo now has tunes again and dashboard lights! Next job is to finish making the slide out bed in the back as she's a camper car. Then when lockdown lifts I'll be off with my daughter on adventures again Big Grin
Reply
#9
Well done mate!
My Van: 2012 B9 1.6 HDi Enterprise 
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
hello all
Last Post: OnlineBlackMagicSpecialist
Today 07:42 PM
» Replies: 0
» Views: 30
1.6 HDI out 1.9D in, is this a straight forward ...
Last Post: cancunia
Today 02:08 PM
» Replies: 3
» Views: 532
Advice on engine noise (fan) after switching off
Last Post: cancunia
Today 02:05 PM
» Replies: 2
» Views: 118
Second USB Socket
Last Post: hc98br
Today 08:56 AM
» Replies: 0
» Views: 153
Seat belt/Airbag warning
Last Post: cancunia
Today 06:41 AM
» Replies: 1
» Views: 270
Alloy wheels ?
Last Post: Easterneye
Today 02:54 AM
» Replies: 0
» Views: 187
Hi
Last Post: Easterneye
Today 02:48 AM
» Replies: 0
» Views: 195
Rear tyre wear
Last Post: Satellitemark
Yesterday 07:00 PM
» Replies: 12
» Views: 1479
Enterprise Touch Screen removal
Last Post: Shane04
Yesterday 05:27 PM
» Replies: 7
» Views: 2173
Hello there
Last Post: geoff
08-07-2020 06:09 PM
» Replies: 1
» Views: 150

[-]
Recent Visitors
Locations of visitors to this page