Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AC button problem
#1
Hello 
Yesterday drove my 2010 M59 1.6HDI all day with AC on and it worked good. On steep hills im shutting down the AC compressor pressing the AC button on the tash to help the small 75hp climb up and turning it back on after iv passed it. 
The AC button and AC system worked fine all day on 30c+ outside , but in the evening on the way home (about 26-7c outside) at some point iv tried to turn on the AC again but the button wont react and wont light up the small yellow light that shows the compressor is engaged. pressed it few times until i got home and nothing - the button wont light up and the AC compressor wont engaged.
Today i went to start looking for the issue on the system, first thing i did was starting the car and turn on the AC system and now it works fine again as it should. pressing on the AC button turns on the compressor and cold air is getting in.
At no point the car overheated - my temp gauge sits very steady on 1 line under the middle point (90) and gets there very rarely.
I dont want it to happen again as it will probably will at the least comfortable situation, so im asking what could be the cause for this issue?
Thanks
Reply
#2
(11-06-2020, 09:53 AM)Shasha127 Wrote:  Hello 
Yesterday drove my 2010 M59 1.6HDI all day with AC on and it worked good. On steep hills im shutting down the AC compressor pressing the AC button on the tash to help the small 75hp climb up and turning it back on after iv passed it. 
The AC button and AC system worked fine all day on 30c+ outside , but in the evening on the way home (about 26-7c outside) at some point iv tried to turn on the AC again but the button wont react and wont light up the small yellow light that shows the compressor is engaged. pressed it few times until i got home and nothing - the button wont light up and the AC compressor wont engaged.
Today i went to start looking for the issue on the system, first thing i did was starting the car and turn on the AC system and now it works fine again as it should. pressing on the AC button turns on the compressor and cold air is getting in.
At no point the car overheated - my temp gauge sits very steady on 1 line under the middle point (90) and gets there very rarely.
I dont want it to happen again as it will probably will at the least comfortable situation, so im asking what could be the cause for this issue?
Thanks
The computer system on aged Berlingos seems to suffer from mild dementia. I've had similar issues with the reversing sensors amonst other things. These problems baffle most engineers and you may end with big bills at the garage, I just pat it on the bonnet and say I understand.
[-] The following 1 user says Thank You to Bootlebarth for this post:
  • RJBingham
Reply
#3
It could be worth doing a BSI reset, if your M59 has a BSI (I think it did by 2010) as all buttons go to the BSI or ECU and they in turn, action the request.

The other thing could be slightly low gas pressure, that can cause the system to stop running, once it had cooled, it works again.

If the condenser pressure gets too high also, during hot weather and there is not sufficient cooling available to bring the pressure down, a pressure switch will trip and stop the compressor from running, but auto-resets once the temperature of the condenser drops - which then allows it to work again.

So check the fan is running when AC is on, and whether the gas needs topped up.
______________________
Current:
2017 B9 1.6 BlueHDi Van
______________________
Previous:
2012 B9 1.6 HDi Van
2008 M59 1.6 HDi Van
2003 M59 1.9D Van
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Berligo 2012 heater blower
Last Post: Marcus6966
Today 08:05 AM
» Replies: 0
» Views: 4
Front Seats 2004 multispace.
Last Post: Romahomepete
Today 07:29 AM
» Replies: 4
» Views: 68
2009 B9 Multispace recently bought
Last Post: Zion
Today 06:50 AM
» Replies: 2
» Views: 73
Vehicle tax
Last Post: John Bilko
Today 12:07 AM
» Replies: 10
» Views: 339
Missing center console, alternatives?
Last Post: Matt Haigh
Yesterday 11:14 PM
» Replies: 2
» Views: 101
Turn signal and headlights short circuit
Last Post: saskak
Yesterday 04:50 PM
» Replies: 3
» Views: 81
throttle position sensor
Last Post: Zion
Yesterday 03:45 PM
» Replies: 5
» Views: 84
New
Last Post: Zion
Yesterday 02:43 PM
» Replies: 1
» Views: 46
Annoying...
Last Post: Zion
Yesterday 02:42 PM
» Replies: 6
» Views: 153
Roof rails for k9 2022
Last Post: OlliL86
Yesterday 12:52 PM
» Replies: 20
» Views: 692

[-]
Recent Visitors
Locations of visitors to this page

[-]
Hosting by

QuickHostUK