Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] STOP light has come on/no indicators
#1
After fitting a new stereo, it seems I have inherited a problem..STOP is flashing on my dash and I have lost use of the indicators!
 When I turn on the ignition..only the oil can light is showing on the dash, no heater-plug light...?
 Headlights, lecky windows, wash/wipers all work fine...and I cannot see any blown fuses..?  Has the management system chucked the teddy out..?  Is there a way of 'resetting' it all..?  Many thanks in advance..U.S.
Reply
#2
A BSI reset perhaps , mainly consists of dis connecting the battery and reconnecting .

There will be instructions on how to do it properly, try the search box . It may or may not cure the problem but its worth trying
2010 B9 red XTR w a v. 
2001 1.9d DW8B white  Berlingo  
2005 2.l green Berlingo
2001 1.9d DW8B white  Berlingo 
1993 xud 1.9 red partner
[-] The following 1 user says Thank You to brodfather11 for this post:
  • Usual Suspect
Reply
#3
Try the battery reset, you may not have a BSI due to it being an M49, but disconnect the stereo and see if the fault goes away. It may be causing the issue by grounding a wire that shouldn't be, on the new stereo plugs.
My Van: 2012 B9 1.6 HDi Enterprise
[-] The following 1 user says Thank You to Zion for this post:
  • Usual Suspect
Reply
#4
Disconnected the stereo, singled out each wire from the plug, reconnected the battery, all fuses appear to be good..indicators not working, clock working, but time change button not working..? Still got 'STOP' showing on the dash, and no heater-plug lamp showing..? 'STOP' stays on for about 30 seconds after taking key out..then a faint click, and it goes out..Have I somehow fried the flasher-unit..?
Reply
#5
Not sure mate. The time change buttons may never work again once the stereo is swapped, as it's the master ECU for the time display. You do seem to have inherited an electrical gremlin. Have you properly checked all fuses? Cabin and engine bay? Not just visually but continuity checks with a meter.
My Van: 2012 B9 1.6 HDi Enterprise
Reply
#6
Zion..Thank you..I've only visually checked the fuses..Will need to do proper check as you suggested..speedo & tachometer not working, but temp & fuel gauges do...yep, there's something goin' on in there..?
Reply
#7
After removing some clips (may be rivets on your model) there should be a set of large master (MF) fuses under the normal tray of fuses in the engine bay fusebox. It does seem like you've blown something when you swapped the stereo. You're not the first to post that their van or car has gone nuts after a stereo swap. Something must be incompatible and it seems to stick once it's happened. That suggests a fuse, or damaged wire from ECU to cluster. On later models the cluster is electronically linked to the stereo. I'd have a good look at the harness between cluster and stereo plugs too.
My Van: 2012 B9 1.6 HDi Enterprise
[-] The following 1 user says Thank You to Zion for this post:
  • Usual Suspect
Reply
#8
Which year model is your car?
Pre-2000 and post-2000 have 'a few' differences...

What happens if you disconnect the stereo?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Installing 12V and USB power in the boot and a t...
Last Post: Romahomepete
Today 07:19 AM
» Replies: 7
» Views: 922
Speedo fault?
Last Post: Softweigh
Today 06:34 AM
» Replies: 26
» Views: 3392
Roof Rack Blanking Plug Removal
Last Post: theraginganarchist
Yesterday 09:51 PM
» Replies: 23
» Views: 2146
MOT Passed!
Last Post: ffrenchie
Yesterday 08:04 PM
» Replies: 5
» Views: 2142
help with alloy wheel locking bolt
Last Post: Mike
Yesterday 06:50 PM
» Replies: 17
» Views: 1387
Mountain Bikes inside
Last Post: Bromptonaut
Yesterday 05:15 PM
» Replies: 11
» Views: 2025
Recommend a tailgate holder bracket for a liftin...
Last Post: lakeside
Yesterday 03:23 PM
» Replies: 3
» Views: 442
Fault Code P000E
Last Post: Bromptonaut
Yesterday 02:59 PM
» Replies: 5
» Views: 357
Can Berlingo XL 2020 front seat convert to swive...
Last Post: Rasputin
Yesterday 02:23 PM
» Replies: 2
» Views: 601
Install after market front fog lights
Last Post: Tree
Yesterday 02:23 PM
» Replies: 2
» Views: 154

[-]
Recent Visitors
Locations of visitors to this page