Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DAB radio problems
#1
Hi we have a 2015 Enterprise berlingo van and the dab display keeps turning on and off . We have problems with the beeping and solved that by holding the
up and down volume buttons together. Is there any way of sorting this annoying problem out without dealership intervention Thanks Jim
Reply
#2
Do you mean the 7" touch screen keeps re-booting?
B9 (2016) 1.6 BlueHDi 100 Multispace XTR = Mine;   B9 (2013) Enterprise 1.6 HDi Van = Hers.
Reply
#3
(30-09-2020, 03:42 PM)Pedronicus Wrote:  Do you mean the 7" touch screen keeps re-booting?
yes the screen 2015 enterprise the one just before the adblue model
Reply
#4
Have a look here: https://www.berlingoforum.com/thread-12154.html.  Could be a software issue.

Funnily enough I had the touchscreen on the XTR reboot three times on my trip back from Portsmouth to Surrey yesterday whilst listening to a DAB station but 'er indoors who went to Gatwick to pick up daughter earlier today had no probs at all.
B9 (2016) 1.6 BlueHDi 100 Multispace XTR = Mine;   B9 (2013) Enterprise 1.6 HDi Van = Hers.
Reply
#5
mine has started doing this ..... every 3mins 10 secs for a hour and half drive yesterday ... nearly smashed it out of the dash
Reply
#6
(03-10-2020, 05:57 PM)iggyleigh Wrote:  mine has started doing this ..... every 3mins 10 secs for a hour and half drive yesterday ... nearly smashed it out of the dash

Mine too started a couple of weeks back.

Berlingo Enterprise Van 2015

Did yours perchance start doing this after a service/mot ?

Very annoying
Reply
#7
Just a thought.  As all the recent issues have occurred about the same time I wonder if it was anything to do with the DAB signal rather than the vehicle software.  I haven't been out in mine recently so can't tell if the problem is ongoing.

One other point - the 'service due' notification had just popped up a couple of days before I had the problem - I wonder if it's a 'cunning ploy' by Citroen to get you to book a service!!!   Rolleyes
B9 (2016) 1.6 BlueHDi 100 Multispace XTR = Mine;   B9 (2013) Enterprise 1.6 HDi Van = Hers.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
COM2000 variants
Last Post: Rasputin
Yesterday 11:28 PM
» Replies: 15
» Views: 528
Installing 12V and USB power in the boot and a t...
Last Post: mission
Yesterday 06:54 PM
» Replies: 2
» Views: 419
Speedo fault?
Last Post: Zion
Yesterday 04:48 PM
» Replies: 18
» Views: 1350
Radio Reboot Issues Back Again
Last Post: willjam39
Yesterday 02:09 PM
» Replies: 2
» Views: 592
Coolant leak from rear flange - how to replace?
Last Post: GregS
Yesterday 01:06 PM
» Replies: 0
» Views: 154
Roof Rack Blanking Plug Removal
Last Post: Softweigh
Yesterday 12:42 PM
» Replies: 8
» Views: 605
Oil
Last Post: Mike
Yesterday 12:22 PM
» Replies: 9
» Views: 446
2010 1.6 HDI consul display fault
Last Post: Zion
Yesterday 09:34 AM
» Replies: 1
» Views: 216
Towbar woes
Last Post: ffrenchie
Yesterday 06:46 AM
» Replies: 10
» Views: 795
What are these bolts for ?
Last Post: lazy_pete
20-10-2020 08:52 PM
» Replies: 6
» Views: 845

[-]
Recent Visitors
Locations of visitors to this page